Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Mustafa_Atıl_B_
Beginner
47 Views

The application running smoothly in the simulator is a problem when applied to the phone.

problemxdk_0.jpg

Tags (2)
0 Kudos
3 Replies
PaulF_IntelCorp
Employee
47 Views

I suggest you debug directly on the device. See this doc page for recommendations > https://software.intel.com/en-us/xdk/docs/intel-xdk-debug-and-test-overview <

Mustafa_Atıl_B_
Beginner
47 Views

 

Thank you Paul. 

I've studied the page you shared. I've tried all of them. But the same problem still continues. I'm running my application on the device. But I want the page to be refreshed when a button is pressed. This renewal will not be in the loading state. This process is running in the simulator. But when I try it on the devices, this one feature does not work.

PaulF_IntelCorp
Employee
47 Views

I cannot tell for sure, but when I look at your screenshot it appears that you are building a "multi-page app," rather than a "single-page app." Please see this Cordova doc for some background > http://cordova.apache.org/docs/en/6.x/guide/next/index.html#best-practices-cordova-app-development <

Each time you load a new page it results in a re-initialization of the webview. Loading multiple HTML pages is not recommended for this type of app (a Cordova app). If those HTML files are templates that are merged into an existing index.html page, that is a different story. Either way, using the debugger on the real device is going to be the best way to uncover what is causing the slow behavior of your app.

Reply