Software Archive
Read-only legacy content

USB debugging for Intel XOLO

Kishor_D_
New Contributor I
1,193 Views
We are developing app for Xolo. We are trying to USB debug the app using Xolo, but Eclipse is not detecting Xolo as a device. We have installed Intel USB drivers. Please help.
0 Kudos
1 Solution
Anvesh_K_
Novice
1,194 Views

I think how it how can be done, Kishore, I understand your frustration

1. Install 1.1.4 drivers.

2. Connect mobile, Open device manager, it shows "Android Phone" with exclamatory mark!

3.Right click and open properties.Go to Details tab. In "property" select hardware id's. Remember the VID and PID. Xolo's VID for mine is 1D91, and my PID is AABC.

4. Open the intel drivers folder in program files. and open the *.ini file, replace VID 8087 (this is for Orange San Diego, intel needs to change that) with your VID, and also your PID.

5. You need to save those files, with admin previliges its possible.

6. Now remove and connect Mobile. Go to device manager. You may or may not see any changes. Right click and click update. Select Browse from my computer, and then Let me pick, you'll have 3 options "ADB", "Bootloader", "Composite", choose according to your use. After the update is success, restart everything.

7. Now possibly the adb devices command may show "List of devices attached" with empty list. If it shows your mobile ID, no problem. If it does'nt, then go to, "C:\Users\user_name\.android" folder, create a file named "adb_usb.ini" and type and save "0x1D91" in that file. it is the VID in hex . If you have a different VID use it.

8. I believe you then will be able to use your mobile in debugging. I did. I hope you do too. If its a success, please contact me.

View solution in original post

36 Replies
Anvesh_K_
Novice
1,195 Views

I think how it how can be done, Kishore, I understand your frustration

1. Install 1.1.4 drivers.

2. Connect mobile, Open device manager, it shows "Android Phone" with exclamatory mark!

3.Right click and open properties.Go to Details tab. In "property" select hardware id's. Remember the VID and PID. Xolo's VID for mine is 1D91, and my PID is AABC.

4. Open the intel drivers folder in program files. and open the *.ini file, replace VID 8087 (this is for Orange San Diego, intel needs to change that) with your VID, and also your PID.

5. You need to save those files, with admin previliges its possible.

6. Now remove and connect Mobile. Go to device manager. You may or may not see any changes. Right click and click update. Select Browse from my computer, and then Let me pick, you'll have 3 options "ADB", "Bootloader", "Composite", choose according to your use. After the update is success, restart everything.

7. Now possibly the adb devices command may show "List of devices attached" with empty list. If it shows your mobile ID, no problem. If it does'nt, then go to, "C:\Users\user_name\.android" folder, create a file named "adb_usb.ini" and type and save "0x1D91" in that file. it is the VID in hex . If you have a different VID use it.

8. I believe you then will be able to use your mobile in debugging. I did. I hope you do too. If its a success, please contact me.

Kishor_D_
New Contributor I
427 Views

Hi Anvesh K.,

Thanks for your reply.

I installed 1.1.4 drivers.

I updated *.ini files with VID and PID. But when I try to update drivers, it doesn't shows options like "ADB", "Bootloader", "Composite".

Please find attached screen shot.

Thanks,

Kishor

 

Kishor_D_
New Contributor I
427 Views

Hi Anvesh K.,

I installed above drivers. Previously I was having 1.1.3.

Not it's working fine.

Thanks,

Kishor

 

 

JLuna5
New Contributor I
427 Views
Anves K. Nice post!
Jayaraman_S_N
Beginner
427 Views

Hello Anvesh K,

  Thank you very much. Worked for me too.

Charis_M_
Beginner
427 Views

Anvesh, Kishore, Jayaraman,

Need help...Its heartening to see that you guys have managed to get adb to start, however am facing issues and extremely frustrated that I cant get it to work!!!

Win 7 x64 /Android device drivers 1.1.4/Java jdk1.8.0_05 and Jre8/Android SDK installer_r23.0.2/ Android SDK Platform tools

Issues that I am facing:

A) Where do you have the "ini" file to change the VIDs and PIDs??? Are we talking about the .inf files in the installation folder? there are 5 of them - android_winusb, gadget_multi, gserial, intelmtp and rndis. Are we looking at changing the VIDS and PIDS in all of them????

B) In Anvesh's post above

Now remove and connect Mobile. Go to device manager. You may or may not see any changes. Right click and click update. Select Browse from my computer, and then Let me pick, you'll have 3 options "ADB", "Bootloader", "Composite", choose according to your use. After the update is success, restart everything.

I only get to see ADB - Boot loader and composite are not available as options.If I try to update the driver by selecting ADB, Windows cant find it on the disk, and insists on installing a Acer I110 ADB Interface as the device driver, which I have deleted.

Where am I going wrong with this? This is extremely frustrating!

Any inputs? Thanks in advance!

 

Anvesh_K_
Novice
427 Views

Charis

I understand your frustration, I went through the phase myself, and there's a lot like us, we even have a group on facebook to discuss our problems. 

 

1. The ini files in the folder, each has a significance. If you only want to use adb, the android_winusb should suffice I believe. But lets say you want to use USB tethering from mobile to PC, then you should also have changed rndis.ini. So I recommend changing the VID and PID's in all of them, leaving the modes (M01, M02 etc) unaltered.

2. If you have only edited 1 or a few lines leaving others as is, then may be these modes are ignored. (Bootloader and Composite). So try changing VID and PID's in all lines. And even if it does not work, adb itself should be sufficient isn't it? Because I for one, cannot access the bootloader of our device and my friends at Facebook too.(beware it has a whole different VID PID set, and also rndis(tethering)mode has its own). 

 

Here is the link to the group at facebook,  https://www.facebook.com/groups/x.910.xolo/

and a screenshot tutorial on how to enable adb.  

https://www.facebook.com/media/set/?set=oa.674635955921765&type=1

 

If time allows me, I will try to create a screencast on this topic.

Anvesh_K_
Novice
427 Views

A link to the video I made.

http://youtu.be/JeSVgyPvSyQ

Kishor_D_
New Contributor I
427 Views

Hi Anvesh,

Very good Work!

Thanks,

Kishor

 

Ehtesham_K_
Beginner
427 Views
Can any body tell how to find *.ini folder because it not appearing in my intel android foldr
Ehtesham_K_
Beginner
427 Views
Pls help me with procedure to enable usb debugging in my xolo X910 as i want to root it now. Pls each and every step.
Ehtesham_K_
Beginner
427 Views
Can anybody give the snapshot of full process for usb dri er install and root of xolo X910
Sanjeet_G_
Beginner
427 Views

i have got cracked the screen of my xolo A600....now i am not able to access the phone. i have all of my contacts in the phone memory. now i need to backup my contacts. for this i downloaded xolo a600 pc suit also but it need the USB DEBUGGING enable in my phone option. now please help how could i enable USB DEBUGGING without using screen..thanx

Sanjeet_G_
Beginner
427 Views

could someone help me out..will be greatful..

 

Alexander_W_Intel
427 Views

Hi Sanjeet,

I'm not aware how this should possible. The security system does not allow this. 

Did you enabled the Google account on your device? If yes the Contacts most likely are available at the gmail website. Click on contacts there. 

Alex

edo_communication
427 Views

Alexander Weggerle (Intel) wrote:

Hi,

Do you have USB-Debugging activated? Go to Settings -> Applications -> Development -> USB debugging.

Without that the phone will not be recognized.

Alex

how too write imei android chipset intel atom??? please  help me instruction

Reply