Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
31 Views

Unable to create a signed version of Intel App Preview - cloud server issue?

Hi,

I'm trying to debug an iOS app via the Intel XDK "Debug" tab. It tells me that it "cannot detect a properly signed version of App Preview"... When I follow the instructions, I get an error along the lines of "Error encountered while creating a signed version of App Preview. Suggestion: Retry."

I've checked the other forum posts relating to this, and I'm wondering if it's a cloud-server issue again? As mentioned in the following post:

https://software.intel.com/en-us/forums/intel-xdk/topic/639618

Mon, 06/13/2016 - 17:24

There was an issue with the signed App Preview mechanism in our cloud-servers over the weekend. That issue has been resolved. Please try it again.

I also checked the following post:

https://software.intel.com/en-us/forums/intel-xdk/topic/629312

and made sure that I followed all the details as specified here:

Mon, 05/09/2016 - 09:23

What version of iOS is on your device? Someone else was having a similar problem and it was due to the fact that they their device is running iOS 7. When you build a signed (debuggable) version of App Preview, it will sign the latest version of App Preview for you. The latest version only runs on iOS 8 and higher.

Also, was the cert and mobile provisioning file you provided to sign App Preview a "development" cert?

Did you configure the mobile provisioning file so it uses a "wildcard" for the App ID?

Did the development cert you generated include the UID for your device in the list of allowable devices?

My situation:

I've tried repeating this process a couple of times, and I've even tried uploading the created .ipa file to the phone via iTunes. I just cannot get it to work :-(

Any suggestions?

Thanks in advance!

Tags (2)
0 Kudos
5 Replies
Highlighted
Moderator
31 Views

Kerryn - I will check into this.

0 Kudos
Highlighted
Moderator
31 Views

It seems to be working here. You will get that error if you type the password incorrectly. Could that be the issue?

If that isn't it, tell me where in the process you are when you get that error.

0 Kudos
Highlighted
Beginner
31 Views

Hi Pamela :-)

I don't believe it's an incorrect password issue, as it gets quite far in the process before it fails. It appears to fail when it tries to load the created .ipa file to the device.

I say this, because it prompts me to specify where to save it and what file name to use. I use an arbitrary location on my computer (I've even tried different locations), and save it as "intelapppreview.ipa" (I've also tried using different names). It creates a file roughly 8MB in size if I remember correctly, and gets so far as deleting the unsigned app off of the device.

Thanks for helping me look into this...

0 Kudos
Highlighted
Beginner
31 Views

Hi :-)

I have finally managed to get a signed app preview onto my device! I just want to post what I found, in case it helps someone else.

At a loss of what else to do, I decided to recreate my .p12 file. When I went into the Mac's Keychain application (I usually work on a Windows machine, and only ever use the Mac for certificate requests and .p12 file creation), I discovered an error message associated with my current, valid development and distribution certificates: "This certificate has an invalid issuer".

I Googled it, and discovered that my WWDR certificate had expired earlier this year. This page was helpful in helping me figure it out: http://stackoverflow.com/questions/35390072/this-certificate-has-an-invalid-issuer-apple-push-servic...

I don't really know how this certification stuff all works, but I figured it may have affected the validity of the .p12 file I was using. So, I downloaded a newer version of the WWDR certificate (one that expires in 2023): https://developer.apple.com/certificationauthority/AppleWWDRCA.cer, and recreated the .p12 file.

I then uploaded this new .p12 file when prompted, and after a few failures (which appear to have been internet connectivity based, as the .ipa file remained at 0KB) and retries, it worked :-) The final .ipa file was 8 349 KB :-) I don't believe the initial failure was internet connectivity based, as the generated .ipa files were all that size too - they only failed when Intel XDK tried to load them onto the device. Otherwise, everything remained the same, so I can only assume it was the .p12 file causing the issue.

In summary, to get a signed App Preview onto an Apple device:

When prompted by Intel XDK:

The test device must be running iOS 8 or above, and it's UID must be included in the list that was used to create the mobile provisioning file.

***It may require more than one attempt to load the signed app preview, especially if there are connectivity problems.

0 Kudos
Highlighted
Moderator
31 Views

Kerryn,

Thank you for following up to help other users.

Pamela

0 Kudos