Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
39 Views

Urgent problems with RealSense JavaScript API (Web Runtime)

Hello all,

I am currently not able to run the RealSense JavaScript API (using RealSense Web SDK Runtime). The errors started to occur last Thursday (2016/04/14) afternoon (CEST). Up until now, all the samples were running fine on all the tested machines.

Since we really need the JavaScript API to work for our talks concerning Intel RealSense, could you please have a look at this issue ASAP?

The behavior is the following:
Running one of the JavaScript sample apps from the Intel RealSense SDK browser, when I try to use the RealSense Web Runtime, I get the following error message on the browser console:

POST https://192.55.233.1/resourceaccesstoken 400 (Error)

The response is the following:
 
{ "error": {
  "code":400,
  "errors":[ {
    "domain":"CapabilityProxy",
    "extendedHelp":"",
    "message":"",
    "reason":"CP-001",
    "sendReport":""
  }],
  "message":"Invalid parameter received in request.",
  "requestId":8
} }

Trying to check the health seems good:

{ data: {
  kind: "healthcheck",
  isHealthy: true,
  name: "capabilityProxy",
  build: "1021",
  version: "1.9.0"
} }
{ data: {
  kind: "healthcheck",
  isHealthy: true,
  name: "capabilityProxy",
  build: "1021",
  version: "1.9.0"
} }
Content of "C:\ProgramData\Intel\Intel(R) Technology Access\Logs\Intel(R)TechnologyAccess.log":
 
I0419 21:09:39.967974  5628 PowerSink.cpp:94] PowerEventType::PowerResume
I0419 21:09:39.967974  5628 EventObserver.cpp:110] Power Change Event: Resume
I0419 21:09:39.982985  6804 EventObserver.cpp:166] Interface Change Event
I0419 21:09:39.987989  2956 DevKeyReader.cpp:468] Found the installer reg key, breaking
I0419 21:09:39.992992  6804 PowerSink.cpp:94] PowerEventType::PowerResume
I0419 21:09:40.606825  2644 EventObserver.cpp:110] Power Change Event: Resume
I0419 21:09:48.618916  5628 EventObserver.cpp:166] Interface Change Event
I0419 21:09:52.002326  2956 DevKeyReader.cpp:468] Found the installer reg key, breaking
I0419 21:09:54.342195  5628 EventObserver.cpp:166] Interface Change Event
I0419 21:10:05.060659  1644 EventObserver.cpp:166] Interface Change Event
I0419 21:10:32.868113  5628 EventObserver.cpp:166] Interface Change Event
I0419 21:10:42.886519  1644 EventObserver.cpp:166] Interface Change Event
I0419 21:10:52.906141  6804 EventObserver.cpp:166] Interface Change Event
I0419 21:12:44.686020  2996 Telemetry.cpp:278] Flushing telemetry data
I0419 21:12:44.686020  2996 Telemetry.cpp:294] Done flushing telemetry data
I0419 21:12:44.699936  2760 AccessTokenHandler.cpp:142] No authorization point found for capability: realsense/rssdk_v7
I0419 21:12:44.699936  2760 AccessTokenHandler.cpp:151] Failing authorization request because we found: 0 authorization points but needed exactly 1
I0419 21:13:55.776490  2768 AccessTokenHandler.cpp:142] No authorization point found for capability: realsense/rssdk_v8
I0419 21:13:55.776490  2768 AccessTokenHandler.cpp:151] Failing authorization request because we found: 0 authorization points but needed exactly 1
 
I tested the Web Runtime on 3 different systems and came to the same result on all three of them:
  • Lenovo Yoga 3 Ultrabook, Intel 5Y70, Intel HD Graphics 5300, external F200 camera
  • Asus laptop with Intel Core i7 4720HQ, Intel HD Graphics 4600, integrated F200 camera
  • Dell All-In-One with Intel Core i5 6300HQ, Nvidia Geforce 940M, integrated F200 camera
All get the same error.

The problem occured in:
  • Windows 8.1 (Home)
  • Windows 8.1 (Pro)
  • Windows 10
Browsers tested:
  • Google Chrome (new update)
  • Firefox 45.0.2
The problem was present using the following RealSense SDKs (with mathching Web Runtime version):
  • R5 version 7.0.23.8048 (with DCM for F200 1.4.27.41944)
  • R6 version 8.0.24.6528 (with DCM for F200 1.4.27.41944)
All the systems were running the C# and C++ systems correctly.
 
Tested in 2 countries (Germany and Netherlands) ;-)
0 Kudos
6 Replies
Highlighted
39 Views

Thanks for the complete right up Thomas. We're tracking progress on getting the fixed ITA version posted on https://software.intel.com/en-us/forums/realsense/topic/625015

0 Kudos
Highlighted
Beginner
39 Views

Thanks again for addressing the issue. Is there an update on this issue?

0 Kudos
Highlighted
Beginner
39 Views

https://software.intel.com/en-us/forums/realsense/topic/628745 ;

solution on this page , it worked for me.

0 Kudos
Highlighted
Beginner
39 Views

Thanks. I'll try that today.

0 Kudos
Highlighted
Beginner
39 Views

It worked! Thanks for pointing to the solution.

Just for future reference: The newest version of the Intel Technology Access (ITA) software fixed the problem.

Details can be found here: https://software.intel.com/en-us/forums/realsense/topic/628745 

0 Kudos
Highlighted
Beginner
39 Views

On one of my laptops, the error occured again the last few days. Reinstalling the SDK and the ITA solved the problem, however.

0 Kudos