Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
10 Views

WIndows UAP Build Fails

I get this warning when I try the Windows UAP 10 build

"Warning: Plugin Application Events appears to be missing the windows platform support required for this build target. The API provided by this plugin may not work on the windows platform."

But can't find what is the appropriate plugin to use - as the ones on the pre-canned list don't work. Any ideas?

Thanks

 

Tags (2)
0 Kudos
3 Replies
Highlighted
Employee
10 Views

which plugin are you trying to use?

After warning are you able to build it?

0 Kudos
Highlighted
Beginner
10 Views

As best as I can tell I removed the plugin dependent on events - this being local notifications. The other plugins I use don't have this dependency. The Windows 8 and 8.1 build without issues. I don't have the full list of plugins and versions to hand but will post in a day or two. 

 

 

0 Kudos
Highlighted
10 Views

Kevin -- the way you can tell if a plugin is supported or not on the Windows platform is by inspecting the plugin.xml file that is present in every plugin. If that plugin includes a section like this (taken from the device plugin):

    <platform name="windows">
        <js-module src="src/windows/DeviceProxy.js" name="DeviceProxy">
            <merges target="" />
        </js-module>
    </platform>

The parts between the <platform> tags are a function of the specific plugin. What is important is the existence of that <platform name="windows"> section. If present, the plugin supports Windows. If not, you will get the warning, because it has no support for the "windows" target. If there is a "windows8" target that may still work.

0 Kudos