Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Arthur_T_
New Contributor I
44 Views

browser/android version support for my standard HTML5 framework7 project

I'm using XDK ver 3240. I would like to know is there any document mention about the browser version supported if I using framework7 and standard HTML5 project.

P.S. I can only found from internet about browser version support for jquery 1.x but not framework7. I guess I don't have to care about iOS/android as I can specify the OS/api version that the app target (like what I did in xcode/android studio)

Tags (2)
0 Kudos
3 Replies
Pamela_H_Intel
Moderator
44 Views

Arthur - Built XDK apps run in a Cordova webview, not in a browser . . . so maybe you want to ask check out Cordova CLI 5.4.1. There is some information at https://cordova.apache.org/docs/en/latest/guide/platforms/android/index.html and https://cordova.apache.org/docs/en/latest/guide/platforms/ios/index.html -- of course you can ignore all the setup info, the XDK builders do that for you.

Please restate your question if this does not help.

Arthur_T_
New Contributor I
44 Views

Sorry, I mean when I build for Web. i.e. when the app run on desktop browser. As my app is a standard HTML5 project.

PaulF_IntelCorp
Employee
44 Views

Arthur -- check the version of the Framework 7 and jQuery libs that are included in the App Designer project (inspect the files inside your project). Then you'll have to see if those versions have any specific browser support requirements. The XDK does not dictate which versions of browsers your app will support, it is dependent on those JS lib files and your own JS that you include in the app.

Reply