Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Kirk_W_
Beginner
82 Views

cannot install on centos linux not supported error

Hi, I'm trying to install the parallel studio xe on a linux cluster running centos 6.6 and it gives me an error of unsupported os. It say that supports only cents 6.5.

 

Even by disregarding the error and installing. I linked everything properly (spent hours on the forums), also I have to mention that I installed on my home directory.

Still I couldn't run a minimal example of hello world with openmp. I was getting error about libiomp.so not found even that I had exported to LD_LIBRARY_PATH.

Also when I tried to run some other program I was getting the issue about the license even thought I had explicitly set the LICENSE_FILE_PATH to the correct path.

I'm trying to understand if centos6.6 is not really supported can someone help me out?

Thanks.

0 Kudos
4 Replies
Jennifer_D_Intel
Employee
82 Views

Hello,

You should be able to use Parallel Studio XE Cluster Edition on CentOS 6.6.  Before you ran the compiler, did you source compilers_and_libraries/Linux/bin/compilervars.sh?  That should set the LD_LIBRARY_PATH for you.  If you are not using /opt/intel/licenses for your license path, is the correct path specified in INTEL_LICENSE_PATH?

Regards,

Jennifer

0 Kudos
Kirk_W_
Beginner
82 Views

@Jennifer D.

thanks for the advice. I had already done those things. Well I've managed to install disregarding the message about os is unsupported.

Finally I managed to make it work. I think there should have been something wrong with silent configuration silent.cfg.

One question though which is not still clear to me is if every time we would have to source?

compilervars.sh

iccvars.sh

ifortvars.sh

thanks!

0 Kudos
Kirk_W_
Beginner
82 Views

Dear Jennifer,

 

allow me to ask you another question. Since I'm installing the intel studio xe on a cluster I've noticed some things in this regard with the problems I was facing above.

You see there is an entry node in which I've install the intel studio xe as a non root user (it works there). But the actual work that I do is usually run on other (compute) nodes and not the entry node in which I connect to. The entry node mounts everything to the compute nodes once you ssh into them. So, all my files and the configurations from the environment variables such as LD_LIBRARY_PATH are still present but when I try to run my computations it says that I've a license for the compiler is not available.

In other words it cannot find the license on compute nodes while it works fine on the entry node.

Any help or suggestions on this issue are more than welcome?

0 Kudos
TimP
Black Belt
82 Views

Kirk W. wrote:

 

One question though which is not still clear to me is if every time we would have to source?

compilervars.sh

iccvars.sh

ifortvars.sh

thanks!

Those 3 scripts are the same, so you need to source one of them.  If you wish to have it sourced each time you open a shell, you may copy the source command into the shell initialization script (~/.bashrc, .....) but this defeats the purpose of making it easy to switch compilers.

0 Kudos