Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Maurice_D_
Beginner
86 Views

Beginner PCM build issues..

Hi there,

I followed the howto and articles here as best I can and here is where I am at:

I built my PCM.exe and installed the PCM Service.  used the winring drives from the web in system32 and my PCM folder.  had issues getting Studio to build a RELEASE build.  the PCM Service and intelpcm.dll would only build in DEBUG regardless of the platform and release configuration requested.. PCM.exe built ok in RELEASE.

2) Both the Performance monitor and the PCM service take a very long time to start.  Perfmon seems to be looking for a config file

"users/xxx/AppData/Local/resmon.resmoncfg"  (At one point I changed the PCM service log on credentials to that user, I have since deleted and reinstalled the service with this message still appearing).

Other than that, PCM works, and counters show up in perfmon.  there is an error on QPI-ll monitoring device not present which I understand may mean the bios or hardware has not made the counters available.  I will check my bios later to see if they are exposed.

Question is, should I be building a DEBUG build? and what could be causing this horrendous lag on perfmon?

Thanks!

 

 

 

0 Kudos
2 Replies
Maurice_D_
Beginner
86 Views

I was able to build my RELEASE version by choosing release in the config for the solution and in the main active control for VS which I had missed.  Now when installed on another system worked great. 

Thanks.

Bernard
Black Belt
86 Views

>>>2) Both the Performance monitor and the PCM service take a very long time to start.  Perfmon seems to be looking for a config file>>>

You can observe PCM startup process with the help of ProcMon tool. The problem is to pinpoint the exact reason for startup lag.

Reply