Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,658 Views

A specific router (Compal CH7284e) causes my AC-7265 driver to crash [HP x360, Win10]

Jump to solution

Hi,

I bought a new laptop a few days ago, and have encountered a problem where my google-fu isn't good enough.

I have connected to a number of routers, and all was fine, until I tried one specific router (which I have to be able to use).

When I connect to this router (2.4 Ghz or 5 Ghz doesn't matter), it works for about ten seconds, and during this time I have no packet loss and good speeds. After about ten seconds, the wifi adapter crashes (I believe), and I haven't found any way to recover other than restarting the laptop. When it crashes, it is no longer visible in the device manager.

The computer is a new skylake HP Spectre x360 with Intel(R) Dual Band Wireless-AC 7265. I'm using the drivers recommended by HP, 18.12.0.3. I'm running an fully updated Windows 10.

The router is a http://https//www.comhem.se/kundservice/support/utrustning/compal-ch7284e-44306 Compal CH7284e, provided by a Swedish cable provider. It is using WPA as security protocol and I can't make any changes to the router (not mine).

I have looked into the event log in Windows, and I can see those messages when it crashes:

A corrected hardware error has occurred.

Component: PCI Express Root Port

Error Source: Advanced Error Reporting (PCI Express)

Bus:Device:Function: 0x0:0x1C:0x1

Vendor ID:Device ID: 0x8086:0x9D11

Class Code: 0x30400

The details view of this entry contains further information.

Intel(R) Dual Band Wireless-AC 7265 : Has determined that the network adapter is not functioning properly.

Miniport Intel(R) Dual Band Wireless-AC 7265, {********-********-********-********-********}, had event Fatal error: The miniport has detected an internal error

Initially I thought it was hardware, but now I'm suspecting the drivers. Have anyone seen something similar, or do you have any ideas how to troubleshoot it?

0 Kudos

Accepted Solutions
Highlighted
Honored Contributor II
6 Views

jaqob,

We understand the Intel® Dual Band Wireless-AC 7265 works with all the other routers you have tried with except for the Compal* CH7284E and we also understand that the settings on the router can not be checked since the router is not yours. In this particular case, we recommend that you try the most recent drivers found in our download center. Here is the link: https://downloadcenter.intel.com/download/25514/Intel-PROSet-Wireless-Software-for-Windows-10 Intel® PROSet/Wireless Software for Windows® 10 - File Name: Wireless_18.21.0_t64.exe

As a second option, you can try the following steps:

1. Disable the Power Saving Funtions: Control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply it to default settings.

2. Change Plan Settings: Change Advanced Power Settings >> Wireless Adpater >> Power Saving Mode and make sure both on Battery and Pluged in are set to Maximum Performance.

3. Also, on Device Manager >> Network Adapters >> Intel® Dual Band Wireless-AC 7265, right click and select Properties and from the Advanced tab, select the value of U-APSD Support to Disabled.

4. Check the value of Transmit Power and make sure it is set to 5. Highest.

5. Set the Wireless Mode to 802.11 a/b/g according to the support mode of this router.

6. Set the HT Mode to HT

7. Set the 802.11n Channel Width for 2.4GHz to limited 20MHz

8. Set the value of Romaing Agressiveness to Lowest.

9. Set the Ad Hoc QoS Mode to WMM Disabled.

*There is one very important point you need to consider. Each country has different its on regulatory rules for wireless product usage. This also could be a cause to the disconnections.

View solution in original post

3 Replies
Highlighted
Honored Contributor II
7 Views

jaqob,

We understand the Intel® Dual Band Wireless-AC 7265 works with all the other routers you have tried with except for the Compal* CH7284E and we also understand that the settings on the router can not be checked since the router is not yours. In this particular case, we recommend that you try the most recent drivers found in our download center. Here is the link: https://downloadcenter.intel.com/download/25514/Intel-PROSet-Wireless-Software-for-Windows-10 Intel® PROSet/Wireless Software for Windows® 10 - File Name: Wireless_18.21.0_t64.exe

As a second option, you can try the following steps:

1. Disable the Power Saving Funtions: Control Panel >> Hardware and Sound >> Power Option >> Set the High Performance and apply it to default settings.

2. Change Plan Settings: Change Advanced Power Settings >> Wireless Adpater >> Power Saving Mode and make sure both on Battery and Pluged in are set to Maximum Performance.

3. Also, on Device Manager >> Network Adapters >> Intel® Dual Band Wireless-AC 7265, right click and select Properties and from the Advanced tab, select the value of U-APSD Support to Disabled.

4. Check the value of Transmit Power and make sure it is set to 5. Highest.

5. Set the Wireless Mode to 802.11 a/b/g according to the support mode of this router.

6. Set the HT Mode to HT

7. Set the 802.11n Channel Width for 2.4GHz to limited 20MHz

8. Set the value of Romaing Agressiveness to Lowest.

9. Set the Ad Hoc QoS Mode to WMM Disabled.

*There is one very important point you need to consider. Each country has different its on regulatory rules for wireless product usage. This also could be a cause to the disconnections.

View solution in original post

Highlighted
Beginner
6 Views

Thanks a lot for that rapid and detailed answer! The updated driver solved my problem, now it is working flawlessly!

Highlighted
Honored Contributor II
6 Views

jaqob,

We are glad to know it works just like you wanted it to.

0 Kudos