Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7657 Discussions

Can't takel always IPv6 when connect to a router

Gnk_k
Novice
2,996 Views

Hi all,

When I try to connect to a router in dual stack line, I don't take always IPv6. 
I'm facing this issue with several intel wireless card:

- ax201

- 9560

- 3165

I have tested several drivers:

22.80

- 22.70.0.6

22.60.06

- 19.51.31.1

 

The fact is that only with intel wireless card I don't get always the global ipv6. For example after a suspension or hibernation of the laptop the device is connected to the network but can't take the global ipv6 so I can't surf on ipv6 network.

Same router but for example using Android or other wireless brand network cards, Realtek, Qualcomm and so on, I always have ipv6.

 

When I don't take ipv6, disconnect or reconnect to the SSID doesn't help but to fix it I have to disable and re-enable ipv6 from windows Wi-Fi proprerties.

 

I found this post: Connectivity Issue IPv6 on Wireless 

I will try to answer below.

 

Moreover:

3. Do you get any error message when trying to get the ipv6 address with the system? If yes, can you provide a screenshot?  

No error is shown

4. Is this the original adapter that came pre-installed in your system or have you changed/installed a new adapter recently? 

Original adapter installed in the laptop

5. Is this behavior happening at home, office environment, or both? 

Both

 

Regards.

0 Kudos
14 Replies
David_G_Intel
Moderator
2,983 Views

Hello Gnk_k


Thank you for posting on the Intel️® communities. Please share with us the following:

  • Laptop models
  • Intel® System Support Utility (Intel® SSU) results 


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
Gnk_k
Novice
2,979 Views

Hi,

Attached info you requested.

 

Thanks

0 Kudos
David_G_Intel
Moderator
2,972 Views

Thank you for the information, let me investigate this request and I will post the updates on the thread.


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
David_G_Intel
Moderator
2,947 Views

Hello @Gnk_k


Please try changing power settings using the following steps:


  • Go to device manager.
  • Expand Network Adapters and locate your Wi-Fi driver.
  • Right-click on your network driver, and select Properties from the context menu.
  • Under the Power Management tab, uncheck the option next to Allow the computer to turn off this device to save power.
  • Click on OK then restart the device and make sure settings were saved.
  • Test after waking up the system.



Also:


  • Check in the device manager if the wake on Magic Packet is enabled.
  • Make sure you're using the latest FW of the router.
  • Are you using a static IPV6 address or DHCP?
  • Please confirm if the third-party network cards have power management options that keep them up or down like the workaround mentioned above?


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
Gnk_k
Novice
2,943 Views

Hi David,

  • Go to device manager. 
  • Expand Network Adapters and locate your Wi-Fi driver.
  • Right-click on your network driver, and select Properties from the context menu.
  • Under the Power Management tab, uncheck the option next to Allow the computer to turn off this device to save power.
  • Click on OK then restart the device and make sure settings were saved.
  • Test after waking up the system. 

About these steps, I can't find "Power Management Tab", I found:

  1. power management mimo and is set to "without SMPS"
  2. Active sospension to disattivation which is set to "Disable"

About second steps

  • Check in the device manager if the wake on Magic Packet is enabled. Is Enabled
  • Make sure you're using the latest FW of the router. I'm sure
  • Are you using a static IPV6 address or DHCP? DHCP
  • Please confirm if the third-party network cards have power management options that keep them up or down like the workaround mentioned above? I confirm. Same configuration as mine

Thank you.

 

0 Kudos
David_G_Intel
Moderator
2,939 Views

Thank you for the update, we are still working on this request. The updates will be posted on the thread.


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
David_G_Intel
Moderator
2,921 Views

Hello @Gnk_k


Please try the following:

  1. Check if IPv6 is enabled, right-click the Start menu and select "Network Connections", or go to Settings and click "Network & Internet"
  2. In the Network & Internet settings window, select your connection type (in our case, "Wi-Fi") on the left pane and then click "Change adapter options" on the right pane then Right-click on your connection and select "Properties" from the drop-down menu.
  3. Your network connection properties will appear.
  4. Ensure that the "Internet Protocol Version 6 (TCP/IPv6)" checkbox is ticked (it is enabled) and click "OK" to save the changes. See if this fixes your issue.

If this doesn't help please confirm if this behavior started recently? Were you able to connect as expected before?


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
David_G_Intel
Moderator
2,901 Views

Were you able to check the previous post?  

Let us know if you still need assistance.  


Best regards,  

David G.  

Intel Customer Support Technician  


0 Kudos
Gnk_k
Novice
2,893 Views

Hi David,

 

as said in my first post on ‎01-17-2022:



@Gnk_k wrote:

Hi all,

When I try to connect to a router in dual stack line, I don't take always IPv6. 
I'm facing this issue with several intel wireless card:

- ax201

- 9560

- 3165

I have tested several drivers:

22.80

- 22.70.0.6

22.60.06

- 19.51.31.1

 

The fact is that only with intel wireless card I don't get always the global ipv6. For example after a suspension or hibernation of the laptop the device is connected to the network but can't take the global ipv6 so I can't surf on ipv6 network.

Same router but for example using Android or other wireless brand network cards, Realtek, Qualcomm and so on, I always have ipv6.

 

When I don't take ipv6, disconnect or reconnect to the SSID doesn't help but to fix it I have to disable and re-enable ipv6 from windows Wi-Fi proprerties.

 

I found this post: Connectivity Issue IPv6 on Wireless 

I will try to answer below.

 

Moreover:

3. Do you get any error message when trying to get the ipv6 address with the system? If yes, can you provide a screenshot?  

No error is shown

4. Is this the original adapter that came pre-installed in your system or have you changed/installed a new adapter recently? 

Original adapter installed in the laptop

5. Is this behavior happening at home, office environment, or both? 

Both

 

Regards.


So obviously your suggestion I had already done it and of course the IPv6 proprieties are enabled.

 

My question now is:

have you ever tried to reproduce the issue or behaviour?

 

Thank you very much.

 

0 Kudos
David_G_Intel
Moderator
2,877 Views

Thank you for the update, we did not get the same outcome when this was tested so please use driver:

If you already tried this and the issue persists, the best option is to contact the laptop OEMs to report this behavior.


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
Gnk_k
Novice
2,867 Views

Thank you David,

 

give me 3-4 days to test and I will let you know.

 

Thank you very much.

0 Kudos
Gnk_k
Novice
2,862 Views

Hi,

 

unfortunatly the issue is still present also with 22.110.

 

So my last chance is contact the all oem of all the devices where I see the issue.

 

Thanks.

0 Kudos
David_G_Intel
Moderator
2,858 Views

That is correct, the best option now is to contact the OEMs to report this issue. Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
KiPe
New Contributor I
2,814 Views

Dear Intel,

 

kindly asking you to reconsider this. There is a number of threads working on this topic. Also, a number of vendors (reading asus here, HP on my end, multiple generations affected). Also, seems to happen with vanilla Intel drivers.

 

My assumption:  the scenario used to recreate the issue on Intel side was insufficient or simply not adequate.

 

 

 

0 Kudos
Reply