Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RCham10
Beginner
493 Views

How to improve the network speed.

I have Dell Inspiron 7386 with an Intel AC9560 which is latest drivers/bios/Win10 clean install.

Whenever the PC goes into sleep mode and is woken again the network speed is only 20mbps(1.6Mbps) versus normal speed of approx 300mbps (40Mbps). The speed can be restored by resetting the adapter.

It is only sleep mode and 5G of the dual band

Dell have replaced the motherboard and the wifi adatper (twice).

How can I troubleshoot this problem. I have had Dell support for 5 hrs on a phone line with them remotely diagnosing, but no luck.

Thanks Richard

 

0 Kudos
25 Replies
Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for submitting your question on this Intel® Community.

 

To look into this issue, we would like to have more information about your system configuration.

 

  • When did this issue start happening?
  • Is your computer new?
  • Are other devices in your environment experiencing this issue?
  • Please generate a system report with the Intel® System Support Utility (Intel® SSU) and attach it to this thread.

 

  1. Intel® SSU Download link
  2. Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".
  3. Click on the menu where it says "Summary" to change to "Detailed View".
  4. To save your scan, click on "Next", then "Save".

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

Hi, Thanks for the reply.

I have been noticing this for about 3 month now, but it may have been a problem earlier. The laptop was 9 month old then. I had noticed a slow down from time to time but assumed it was the connection. I had a NAS hard drive fail and I was testing the network speed to the new one and noticed that sometimes it was really slow.

I was also uploading system backups and photos to rebuild the backups and sometimes a 50Gb was predicticted to take 20hrs but othertimes just one hour - I cancelled the long ones and reset the adapter and that fixed it. I was copying about 2Tb altogether.

I have other PC using the 5G channel too without a problem also I have tried a USB wifi adapter too without any problem.

It is only on 5G and happens when the PC wakes from sleep. If I set the Windows sleep setting to ALWAYS disconnect the network on sleep and on Battery, this auto resets and minimises to problem.

I have the latest Intel wifi driver, which is later than the official Dell one

The other point, if I hibernate rather than sleep, there is no problem either.

I have been trying to find a Sleep setting that turns off the network when going to sleep on power as that would be a reasonable workaround, but curious as to the cause of the problem.

Thanks

Richard

CrystalMark result slow:

[Read] Sequential 1MiB): 1.677 MB/s [Write] Sequential 1MiB: 4.404 MB/s

I found that if I Enabled and Disabled the 9560 Adapter, full speed was returned:

[Read] Sequential 1MiB: 31.876 MB/s [Write] Sequential 1MiB: 37.543 MB/s

SSU trace attached.

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for your response.

 

Since you are currently using a wireless generic drivers, we would like to know if this issue also occurs when running the latest Original Equipment Manufacturer (OEM) driver available for your system. It is worth mentioning that this driver was customized for your sytem, which may improve the overall performance of your wireless connection.

 

Please perform these steps:

 

 

Step 1: Get the latest system-specific driver from your computer manufacturer support.

 

 

Links to third party sites and references to third party trademarks are provided for convenience and illustrative purposes only. Unless explicitly stated, Intel® is not responsible for the contents of such links, and no third party endorsement of Intel® or any of its products is implied.

 

Step 2: Uninstall your Wi-Fi driver.

 

Windows* may have an inbox Wi-Fi driver for your wireless adapter. You can't uninstall an inbox driver (you won't see the "Delete the driver software for this device" option). Proceed to the next step if you start seeing the same version of the driver installed automatically after it’s uninstalled.

 

  1. Go to Device Manager.
  2. Expand the Network Adapters category.
  3. Right-click your Intel Wireless Adapter and choose to uninstall it.
  4. Make sure to select the option to Delete the driver software for this device.
  5. Restart your computer.

 

Step 3: Driver installation.

Locate the driver you downloaded back in Step 1. Run as administrator, and follow the wizard to completion.

 

 

  • If the issue persists, try performing these steps with the generic drivers available at our Download Center:

 

Windows® 10 Wi-Fi Drivers for Intel® Wireless Adapters Version 21.60.2

 

Intel® Wireless Bluetooth® for Windows® 10 Version 21.60.0

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

I have worked methodically through your list and uninstalled then reinstalled the Dell drivers, with rebooting along the way. Then tested, and found no difference.

I then downloaded and installed the latest Intel generic ones as suggested, and rebooted. I rebooted the router too.

Still no difference. See tests attached.

Thanks for the help. and are there any other options?

Richard

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for your response.

 

Could you please let us know if Modern Standby is enabled on your OS?

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

That's an interesting question, and no. CsEnable is set to 0. I did try enabling but that did not resolve the speed issue.

I am enclosing the results of powercfg /a for both plugged in (on power) and battery. If the network is disconnected when asleep, there is no sleep problem on waking. I don't know how to implement this for on power. I set the Network state on the power and sleep to ALWAYS disconnect on Sleep and on Battery.

This is the workaround I am favoring without a proper solution.

Thanks,

Richard

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for providing additional details about this behavior.

 

We will do further research about this and update this thread as soon as possible. 

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Could you please provide us with the following information below?

 

Wireless security method

Encryption Type (Open, RC4, TKIP, AES):

802.1X authentication type (WEP, TKIP, CCMP): 

Key Management Type (PEAP, EAP-FAST):

 

WiFi network environment

802.11n or 802.11ac enabled (None/HT(11n)/VHT(11ac)):  

Channel Width (20 MHz vs. 40 MHz) for 2.4 GHz?

Channel Width (20 MHz vs. 40 MHz vs. 80MHz) for 5 GHz?

SSID stealth mode (hidden or broadcast):

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

The question are getting more difficult. The SSID's are visible, and the encryption is AES according to the wifi properties and WPA2-Personal

The attached is the rest of the data.

I just have combined the Wifi 5 and 2.4 G to a single SSID, which is the status now.

Richard

RCham10
Beginner
143 Views

Hi,

There is a parallel thread running on exactly the same problem here - https://forums.intel.com/s/feed/0D50P00004Up3xdSAB

Richard

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for providing us with more details about your network configuration.

 

We will review it and update this thread as soon as possible.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

OK, but whilst you are reviewing that, please can you include my workaround as I don't know what these settings do but changing them has helped mitigate the problem.

The workaround that I am using which has so far been effective is to change the Adapter advanced properties from Enabled (Default) to Disabled for the both

'Wake of magic package' and the 'Wake on pattern match'.

I have changed the Power/Sleep Network setting from NEVER to ALWAYS turn off the network on sleep on battery, but that doesn't seem to affect it. I am also using the latest generic adapter driver 21.60.2.1, and have enabled Hibernate, which kicks in after 30min of inactivity.

Richard

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for the update.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

Hi Wanner,

I have not closed this question, and thought you may have an update?

Richard

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for your response.

 

This question is still open and we are working on it. As soon as we have an update, we will update this thread.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

To continue troubleshooting this issue, we have sent you an email to the email address associated with your profile. 

 

Please check the recommendations provided and let us know if the issue persists.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

RCham10
Beginner
143 Views

Thanks for the driver update. I have now done two clean installs with the new driver and deleted all the old versions. I am afraid that it hasn't improved the speeds when waking from sleep. The slow download speed is still the same at 1.68MB/s vs a normal speed of about 30MB/s.

It can still be mitigated (most of the time) with the advanced settings for Wake on Magic Package and Wake on Pattern Match being set to DISABLE.

Thanks for the support

RichardDevMan.png

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

Thank you for your response.

 

We will update this thread soon.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

Wanner_G_Intel
Moderator
143 Views

Hello RCham10,

 

We are still doing research on this issue. Could you please provide us with the following information:

 

  1. What is the exact AP model?
  2. How are you measuring the speed(throughput) of your network? Does this com from Control Panel > Network Connections > Wi-Fi Status?
  3. How do you wake your system? Wi-Fi (e.g. by Skype call), or just clicking on power button / open the lid?
  4. What is the sleep time before waking up the computer?

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel