Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7521 Discussions

How to permanently disable Killer Prioritization Engine?

mpilgrem
Beginner
3,255 Views

This is a repeat of https://community.intel.com/t5/Wireless/How-to-permanently-disable-Killer-Prioritization-Engine/m-p/1444489 because the moderator advised asking the question again. That moderator was seeking a screenshot, which I provide here.

I have a Dell XPS 8930 with Killer Intelligence Center (KIC) Version 3.1222.608.4 (it came with the machine), which is installed/updated via Microsoft Store. I have discovered that KIC's feature 'Killer Prioritization Engine' (KPE) stops the SharePoint aspects of Microsoft Teams from working (and some other applications that rely on handshaking are also adversely affected). If I disable KPE, Microsoft Teams and the other applications immediately work as intended. I can disable that KPE feature temporarily in KIC, but it re-enables (without any action from me) from time to time. This seems to happen when the machine goes to 'sleep'.

The toggle used to disable KPE is shown in the screenshot to the right ("Quick Settings" > "Prioritisation Engine"). In the screenshot the option is disabled. It re-enables without my intervention.

My question is this: what do I need to do in order to cause the Killer Prioritization Engine feature to be permanently disabled, as I request?

 

0 Kudos
11 Replies
Steven_Intel
Moderator
3,227 Views

Hello mpilgrem


Thank you for posting on the Intel® communities.


I will research about this. As soon as I have an update, I will let you know.


Best regards,


Steven G.

Intel Customer Support Technician.


0 Kudos
Steven_Intel
Moderator
3,200 Views

Hello mpilgrem,


By any chance have you followed the steps in the article How to Stop Intel® Killer™ Control Center updates from the Microsoft Store (https://www.intel.com/content/www/us/en/support/articles/000058940/wireless/wireless-software.html#:~:text=Open%20Killer%20Control%20Center%2C%20go,and%20Disable%20it%20from%20Startup)?


Best regards,


Steven G.

Intel Customer Support Technician.


0 Kudos
mpilgrem
Beginner
3,196 Views

I am on Windows 11. In the 'Startup apps' tab of Task Manager, Killer Intelligence Center/Rivet Networks LLC (the only 'Killer ...' entry) has a 'Status' of 'Disabled'. I should say, I rarely 'start up' my machine - it is 'always on'.

In 'services.msc' and the 'Services (Local)' pane, the listed `Killer ...` items are (1) 'Killer Analytics Service', (2) 'Killer Dynamic Bandwidth Manager', (3) 'Killer Network Service' and 'Killer Smart AP Selection Service'. The first three have a 'Status' of 'Running', the fourth has no 'Status'. The first and third have a 'Startup Type' of 'Automatic'; the second and fourth have a 'Startup Type' of 'Manual'.

So, it is possible I have followed the first and second steps in the URL (albeit with Killer Intelligence Center, not Killer Control Center). However, it appears I have not followed the optional third step in the URL relating to setting a 'Startup Type' of 'Disabled'. 

Please let me know if I can provide you with any other information.

 

0 Kudos
Steven_Intel
Moderator
3,161 Views

Many thanks for the information provided.


I will keep working on this issue. As soon as I have an update, I will get back to you.


Best regards,


Steven G.

Intel Customer Support Technician.


0 Kudos
KMD23
Beginner
2,968 Views

I had this same issue.  I have a Dell XPS and I spent three weeks with Microsoft 365 support trying to figure out my problem.  They finally referred me to Dell to obtain a clean install of Windows.  After a week with Dell support, I finally got someone who identified the Killer Intelligence Setting and turned off the Prioritization Engine setting and then everything worked fine.  When the prioritization engine was enabled my OneDrive would not login and my Outlook would disconnect continually and would stop responding.  This all started the first week of April so I am assuming that this was due to a Windows Update.  It was quite frustrating and cost me $100 to have Dell figure it out.  I finally had to disable the Killer Intelligence Center in 'Services' to keep it from changing the setting every time my computer restarted.

0 Kudos
mpilgrem
Beginner
2,751 Views

It is helpful to know that KIC can be disabled in that way without ill effect. At the moment, I am still manually disabling the KPE component of KIC each time my machine 'wakes up' or I realise that Microsoft Teams (or other software) is being blocked.

0 Kudos
mpilgrem
Beginner
2,751 Views

Are you still working on the issue? If the solution is to permanently remove/disable the whole of KIC (see KMD23's experience below), can that be done safely and how?

0 Kudos
Ernesto_C_Intel1
Moderator
437 Views

Hello mpilgrem, 


I'd like to ask if you still need assistance on this issue?



Regards,  


Ernesto C. 

Intel Customer Support Engineer


0 Kudos
Ernesto_C_Intel1
Moderator
339 Views

Hello mpilgrem, 


I'm following up on my previous message. If you still need help, I'd suggest doing the following: 


1. Clean installation of the Intel® Killer™ Performance Suite.

2. Disable the Killer start-up process

3. From the task manager, go to services and disable the Killer network service.



Regards,  


Ernesto C. 

Intel Customer Support Engineer


0 Kudos
Ernesto_C_Intel1
Moderator
179 Views

Hello mpilgrem, 

 

This would be my final follow-up on this thread. Since I have not received any response from your end, I'll proceed to close this case. If you require assistance or have questions, please do not hesitate to contact us again.

 

Regards,  

 

Ernesto C. 

Intel Customer Support Engineer


0 Kudos
mpilgrem
Beginner
174 Views

With the passage of time, I can't recall what I did but I think I ended up disabling the Killer processes so they do not start-up. That appears to have had no ill effect on my system or its performance.

0 Kudos
Reply