Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YAhag
Beginner
1,187 Views

Intel 7260 AC dual band slow wifi solution

Hey guys ,

 

I'm writing this because i've been experiencing serious wifi problems with the Intel 7260 AC dual band which came with the MSI GT70-2PE that i've purchased: When i do speedtests on win 8.1 i get at max 30mbps of download bandwith while on ubuntu i get a significantly higher rate of 89 mbps. The thing i noticed is that on ubuntu bluetooth is deactivated or at least no device is paired while on windows i usually have my game controller paired and that has a great influence on bandwith since it's a dual band card.

 

Right now i managed to find a temporary solution to the problem by deactivating U APSD (check the wifi advanced card properties) on windows and by deactivating bluetooth. This way i can get full speed on windows as well..

If you guys have any solution that would allow me to use bluetooth as well as wifi at full speed that would be great

 

Hope to read you soon !
0 Kudos
2 Replies
Kevin_M_Intel
Employee
102 Views

Hi Yassine,

There are some troubleshooting steps you can try and in fact disabling the uAPSD was a very good step.

Try these steps:

  1. Update the BIOS of your computer.
  2. Try as much as possible to clean the Wireless environment. This means to turn off wireless adapters and Bluetooth devices near your system and router.
  3. Try Setting the Security encryption on the router to WPA2-AES. Here you have information:

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm

  1. Run all windows updates.
  2. Uninstall the driver you currently have installed and Install the latest driver:

https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24168 https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=24168

  1. Make sure you update the router's firmware.

Kevin M

DKimb1
Beginner
102 Views

Thank you so much Yassine. My connection to router was 300mbps and still only had about 30mbps download speed. I disabled this and am now connecting to the internet at 70mbps! Thanks!

Reply