Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RShah12
Beginner
2,425 Views

Intel Dual Band Wireless-AC 3168NGW ridiculously slow in linux

I am using Manjaro KDE with the 4.14.34-1-MANJARO kernel. I also have Windows 10 dual booted.

When I connect to my the internet via WiFi, I get speeds like 4kBps with ocassional timeouts in speedtest.net.

Heres the info of lshw:

*-network

description: Wireless interface

product: Intel Corporation

vendor: Intel Corporation

physical id: 0

bus info: pci@0000:03:00.0

logical name: wlp3s0

version: 10

serial: a0:af:bd:a3:ff:02

width: 64 bits

clock: 33MHz

capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless

configuration: broadcast=yes driver=iwlwifi driverversion=4.14.34-1-MANJARO firmware=29.610311.0 ip=192.168.1.102 latency=0 link=yes multicast=yes wireless=IEEE 802.11

resources: irq:131 memory:b4000000-b4001fff

As you can see I have the firmware v29. So the fw is updated.

When I switch back to windows I get my full speed (1 mBps) so windows is unaffected.

I tried running another distro (Ubuntu 17.10) from a LiveUSB and there too the speeds are tremendously slow.

Now if I connect my phone to the same wifi, and use USB thethering to connect my laptop to the internet, the speed is what I expect (1mBps) which I think confirms that it is probably the linux driver thats having trouble.

My laptop is the Acer Aspire A515-51G having the 8th gen Intel i5.

I have also tried switching to another router and the speed is still slow. (~4kBps)

It's really frustrating to have to usb thether my phone every time I use the internet so I can even browse smoothly.

please tell me how can I go about solving this.. because on windows I have NO problems whatsoever. It's only linux distros causing issues.

Edit: Even pinging to my router is unrealisticly slow

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

64 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=4.60 ms

64 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=1.47 ms

64 bytes from 192.168.1.1: icmp_seq=6 ttl=255 time=3.04 ms

64 bytes from 192.168.1.1: icmp_seq=7 ttl=255 time=1.43 ms

64 bytes from 192.168.1.1: icmp_seq=18 ttl=255 time=68.5 ms

64 bytes from 192.168.1.1: icmp_seq=19 ttl=255 time=2.46 ms

64 bytes from 192.168.1.1: icmp_seq=20 ttl=255 time=2.09 ms

64 bytes from 192.168.1.1: icmp_seq=21 ttl=255 time=1.98 ms

64 bytes from 192.168.1.1: icmp_seq=22 ttl=255 time=1.49 ms

64 bytes from 192.168.1.1: icmp_seq=23 ttl=255 time=1.48 ms

64 bytes from 192.168.1.1: icmp_seq=24 ttl=255 time=1.31 ms

64 bytes from 192.168.1.1: icmp_seq=25 ttl=255 time=1.43 ms

64 bytes from 192.168.1.1: icmp_seq=26 ttl=255 time=1.43 ms

64 bytes from 192.168.1.1: icmp_seq=32 ttl=255 time=63.3 ms

64 bytes from 192.168.1.1: icmp_seq=33 ttl=255 time=2.10 ms

64 bytes from 192.168.1.1: icmp_seq=34 ttl=255 time=1.28 ms

64 bytes from 192.168.1.1: icmp_seq=35 ttl=255 time=1.75 ms

64 bytes from 192.168.1.1: icmp_seq=36 ttl=255 time=1.13 ms

^C

--- 192.168.1.1 ping statistics ---

36 packets transmitted, 18 received, 50% packet loss, time 35276ms

rtt min/avg/max/mdev = 1.137/9.023/68.543/20.155 ms

Just see the delay and packet loss

Message was edited by: Rushab Shah

Tags (1)
0 Kudos
2 Replies
RShah12
Beginner
589 Views

Okay so I ran this:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

sudo modprobe -rfv iwlmvm

sudo modprobe -rfv iwlwifi

sudo modprobe -v iwlwifi

From the answer found here: https://ubuntuforums.org/showthread.php?t=2336946&s=fda4b6165a7e5e571896fdf9da5afbf0&p=13545492# post13545492 Ubuntu Forums

This seems to have fixed it but I don't think this is the "Ideal" solution.

idata
Community Manager
589 Views

Hello DroidFreak32,

 

 

Thanks for posting and sharing the workaround for this issue.

 

 

Linux* drivers for Intel® Wireless Adapters are developed through the open source community. Support is provided through there and your distribution communities. For more details, please refer to the following articles:

 

 

- https://www.intel.com/content/www/us/en/support/articles/000005511/network-and-i-o/wireless-networki... Linux Support for Intel® Wireless Adapters

 

- https://wireless.wiki.kernel.org/en/users/support Linux Wireless Community Support

 

 

Please let us know if there's anything else we can do for you.

 

 

Best regards,

 

Eugenio F.