Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MCatl
Beginner
1,274 Views

Intel Dual Band Wireless-AC7260 Desktop and ASUS AC-68U Router problems, troubleshooting

Several times a day, my 7260 card or driver gets into some bad state, where throughput is extremely bad. During these times, all other people in my office also experience an almost complete connectivity interruption and start yelling at me to reboot my computer (which usually clears the condition). I would really like to find some workaround (or proper fix) that would let me keep using this card, because it works well (when it is working).

Here is the relevant state of my machine when "everything is fine". It doesn't look meaningfully different during the broken state, but I'm willing to collect additional information if an Intel engineer can make specific requests about what to collect.

Router: ASUS AC-68U Firmware Version: 3.0.0.4.378_4585

$ uname -a

Linux micahcatlin-computer 3.16.0-34-generic # 47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

 

I understand that there is a newer version of the AC-7260 firmware file which is appropriate for newer Linux kernels (

3.19+https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-7260-ucode-25.16.12.0.tgz iwlwifi-7260-ucode-25.16.12.0.tgz)

but I don't want to switch to an unsupported (by Ubuntu) newer kernel unless it is addressing a specific, well-understood problem.

 

$ lspci

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)

06:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)

$ ls -l /lib/firmware/iwlwifi*

-rw-r--r-- 1 root root 680508 Dec 1 12:45 /lib/firmware/iwlwifi-7260-9.ucode

$ dmesg|grep iwl

[ 2.624994] iwlwifi 0000:06:00.0: irq 45 for MSI/MSI-X

[ 2.636156] iwlwifi 0000:06:00.0: loaded firmware version 25.228.9.0 op_mode iwlmvm

[ 2.644513] iwlwifi 0000:06:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144

[ 2.644562] iwlwifi 0000:06:00.0: L1 Disabled - LTR Enabled

$ sudo iw dev wlan0 get power_save

Power save: off

$ iw dev wlan0 link

Connected to 40:16:7e:58:2c:64 (on wlan0)

SSID: Artillery

freq: 5745

RX: 25826779 bytes (31851 packets)

TX: 6427084 bytes (17552 packets)

signal: -42 dBm

tx bitrate: 702.0 MBit/s

bss flags: short-slot-time

dtim period: 1

beacon int: 100

WPA2 authentication

Can anyone from Intel recommend other experiments to help troubleshoot?

 

 

Regards,

Micah Catlin

0 Kudos
4 Replies
ASouz7
Honored Contributor II
103 Views

Hello MicahCatlin,

Have you checked here first? The support for Linux* is given through this community: https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi

You want to check this for assistance as well: http://www.intel.com/support/wireless/wlan/sb/CS-034398.htm Intel® Wi-Fi Products — Linux* Support for Intel® Wi-Fi Adapters

MCatl
Beginner
103 Views

Thanks aleki_intel for the thought, but I think this is not your standard "support question" and I don't believe it is a problem unique to Linux.

It seems (from the plethora of other stale threads) with people describing problems with 7260 and all OS + driver combinations (Including Windows 7, 8), that this is mostly likely a design problem in the device or firmware. Since most of the other threads have stalled out with customers either returning their devices to retail or giving up with troubleshooting, I think it has been hard for Intel engineers to get a reliable reproduction case to truly troubleshoot and I want to help you guys find an actual solution.

I'm no wifi expert, but in my office I can frequently reproduce this failure condition, and I'm willing to collect and share diagnostics. What can I do to help Intel investigate this problem?

These are the other threads which seem to describe the same problem, and there's not yet a technical solution -- only a bunch of "cargo cult" style suggestions to disable ASPM, disable HT, investigate environmental radio interference, etc. None of these close with an actual solution.

ASouz7
Honored Contributor II
103 Views

Hello MicahCatlin,

Are you using this wireless card in a desktop or laptop? If it is a laptop, we would like to know if this wireless card is the original one the came installed in the computer or was it installed later?

Have you tried this wireless card using Windows* 7 or later? - When you mentioned that other people experience connectivity interruption and request that you reboot your computer to normalize connectivity, what exactly do you mean? Do you use your computer to relay the signal? Could you please provide more details on this please?

MCatl
Beginner
103 Views

Hi, this card is installed in a desktop PC. I'm using the supplied antenna, which is in the same room as the ASUS AC-68U router with line-of-sight.

I have not tried this card with Windows.

There are about 15 other computers in the room, mainly Macbook Pro laptops. When my connectivity drops out, everyone else in the room (associated with the same AC-68U router) also experiences a connectivity drop. When I disable my WiFi card or reboot my computer, then everyone else's connectivity immediately returns to normal. All computers in the room (including mine) are simple clients of the same AP/Router, with nothing exotic (no tunneling, bridging, nat, etc).

Reply