Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KShah9
Beginner
4,032 Views

Intel(R) PRO/Wireless 3945ABG connection problems after upgrading to Win 8.1

Hi guys,

Just recently upgraded to Windows 8.1 on my Gateway laptop with Intel(R) PRO/Wireless 3945ABG. Everything was fine prior to the upgrade from Windows 8. Now, everytime I put the computer to sleep or stand-by, on logging back in the wifi is disconnected. It still shows all the neighborhood routers but won't connect to mine. It gets stuck at "waiting to authenticate". I have to disable and enable the adapter in Network Connections. That fixes it.

Its just annoying that I have to do this every morning or after I've stepped away for a long time. Any help?

I've downloaded the latest driver from Intel but the update tool in Device manager says I've got the latest version. I'm at 13.0.3.137.

Thanks!

0 Kudos
15 Replies
Jose_H_Intel1
Employee
642 Views

Please note that your wireless adapter is only supported in Windows* 7 and older operating systems since it is a legacy product. You may check the articles below for more information.

http://www.intel.com/support/wireless/wlan/sb/CS-034561.htm Intel� Wi-Fi Products; Intel� Wireless Products and Microsoft Windows 8.1*

http://www.intel.com/support/wireless/wlan/sb/CS-031641.htm Intel� Wi-Fi Products; Which operating systems are supported by Intel� Wireless Products?

NScg
Beginner
642 Views

That is strange - in Windows 8.0 out of the box everything works fine.

The answer from intel is definitly wrong.

See my eeror-report /thread/46177 https://communities.intel.com/thread/46177

AE
Beginner
642 Views

I have a workaround:

I have made a Powershell script that restarts the Wifi adapter when the computer is started (or wakes up from sleep/hibernation).

I has solved the issue for me. I have tested it only in Windows 8.1

Download the file below and follow the instructions from included txt file:

1.Open Windows Task Scheduler

2.Import the xml as a new task

3.create a folder in C: drive called "RestartWifi (without the quotes)

4.Copy the Powershell script file restart_wifi.ps1 to this new folder

That's it. When the computer starts, or awakes from sleep, it will reset your Wifi adapter.

https://app.box.com/s/ubimf1u34yosy2uc9cg7 restartWifi.zip - Box

EAnde14
Beginner
642 Views

the script doesn't work with my Windows 8.1 32 bit laptop with Intel(R) PRO/Wireless 3945ABG.

In the device manager, if i deactivate and then activate, then the wifi works again, is´nt that what the RestartWifi

script should simulate.

AE
Beginner
642 Views

There was an error in the scheduled task: An event ID thrown at system wake up was missing.

I've uploaded a fixed version: https://app.box.com/s/ubimf1u34yosy2uc9cg7 restartWifi_v2.zip - Box

I've also changed the task configuration from "Windows Vista" type to Windows 8.1. Now I've tested in 64-bit Windows 8.1 and it worked. In fact, this works with any WIFI card.

Note: It may take some 1-2 minutes for your card to be disabled and enabled once the computer awakes from sleep...

Also, make sure you copy the PS1 file under this path c:\RestartWifi\restart_wifi.ps1

SBhul
Beginner
642 Views

Step 4- when you copy the PS1 file into the new folder. I click on it and it comes up with a notepad and following instructions...

Get-NetAdapter -Name Wifi | restart-netadapter

stop-process -Id $PID

Is that right? Should it open in notepad? I'm not sure what any of this means just don't want network issues on my new windows 10.

HFern4
Beginner
642 Views

I can say that your workaround run in Windows 10 x86 too because I just tested it and I haven´t got any problem now. Thanks you so much.

tflat
Novice
642 Views

It seems to have worked for me as well, windows 10, 32 bit.,

Thanks for the work around!

SBhul
Beginner
642 Views

Step 4- when you copy the PS1 file into the new folder. I click on it and it comes up with a notepad and following instructions...

Get-NetAdapter -Name Wifi | restart-netadapter

stop-process -Id $PID

Is that right? Should it open in notepad? I'm not sure what any of this means just don't want network issues on my new windows 10.

KV
Beginner
642 Views

This is a great find, it was so disappointing that this wasn't working correctly. Thanks very much Catatau.

I did have to make one change though to get it working. The powershell script needs to properly identify the Net-Adapter, on my machine the adapter was named differently. In powershell you can just run Get-NetAdapter to get the list of your adapters. Then in the script change the line.

Get-NetAdapter -Name "your wifi adapter's name here" | restart-netadapter

EAnde14
Beginner
642 Views

Thanks to Catatau and KV, now it works great

My wifi name is"wi-fI"

MB10
Beginner
642 Views

I found a solution more efficient and fast.

I solved the problem by selecting Maximum Performance in the Power Options->Advanced Settings->Wireless Adapter Settings and unchecking the "Allow the computer to turn off this device to save power" setting in the Power Management tab for the Wireless Adapter in Device Manager.

The wi-fi works flawlessly in 8.1 after the settings change.

 

Try!

 

VManu
Beginner
642 Views

Thanks it worked me

JBarb16
Beginner
642 Views

Hello I updated the driver to version 13.4.0.139 and solved the problem

following link to download driver, download the version that matches your operating system.

http://www.driverscape.com/download/intel(r)-pro-wireless-3945abg-network-connection Intel(R) PRO/Wireless 3945ABG Network Connection Drivers Download for Windows 7, 8, XP, Vista

Jose_H_Intel1
Employee
642 Views

I recommend you getting the drivers from the system manufacturer or from Intel instead of a third party website.

http://www.intel.com/support/wireless/wtech/proset-ws/sb/CS-034041.htm Intel® PROSet/Wireless Software — Intel® PROSet/Wireless Software downloads

Reply