Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7429 Discussions

Intel WiFi 6 AX201 160MHz (rev 01) does't work at all (Linux)

mirkojoshua
Beginner
5,096 Views

HI,

my mini PC running Ubuntu 22.04 (kernel 5.19.0-35-generic) with an Intel Corporation Wi-Fi 6 AX201 160MHz (rev 01). Unfortunately this WiFi module doesn't work at all. I can't search the connection and also the WiFi menu is missing from the OS settings.

Bluetooth doesn't work either, but I don't know if the problem is related

I have inserted some attachments with the output of debug commands.

 

Thanks

0 Kudos
1 Solution
Jean_Intel
Employee
4,985 Views

Hello mirkojoshua,

 

Thanks for waiting for a response.

 

This time, we would like to recommend your installing the latest stable kernel version available for your operating system.

 

Best regards,

Jean O.

Intel Customer Support Technician


View solution in original post

0 Kudos
7 Replies
Jean_Intel
Employee
5,032 Views

Hello mirkojoshua,

 

Thank you for posting on the Intel️® communities. We understand that you are unable to properly use the Intel WiFi 6 AX201 160MHz on Ubuntu 22.04.

 

In order to have a better understanding of your issue, please provide me with the following:

  • Did the wireless card work as expected on other Operating Systems?
  • Is this the original adapter that came pre-installed in your system or have you changed/installed a new adapter recently?

 

Also, please provide me with the output for the following reports:

  • To check whether the Wireless adapter is connected correctly: # lspci​ 
  • To check whether this is an iwlwifi issue: # modinfo iwlwifi​ 
    • In case the result there is no output  type: # lsmod | grep iwlwifi​
  • To check whether the suitable firmware is installed: # dmesg | grep “no suitable firmware found!”​

 

Best regards,

Jean O. 

Intel Customer Support Technician


0 Kudos
mirkojoshua
Beginner
5,027 Views
Hi Jean,
Wireless card work on Windows and the adapter is pre-installed with my system.

Have you seen the two files attached to my first post? They contains all requested report
0 Kudos
Jean_Intel
Employee
5,008 Views

Hello mirkojoshua,

 

Thank you for the information provided.

 

We will do further research on this matter and post the response on this thread once available.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,986 Views

Hello mirkojoshua,

 

Thanks for waiting for a response.

 

This time, we would like to recommend your installing the latest stable kernel version available for your operating system.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
mirkojoshua
Beginner
4,969 Views
0 Kudos
Jean_Intel
Employee
4,956 Views

Hello mirkojoshua,

 

Thanks for letting us know that you will try the latest kernel version. We will keep this thread open for a bit to see if the issue is still present after updating the kernel.

 

Let us know if you face any inconvenience.

 

Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Jean_Intel
Employee
4,903 Views

Hello mirkojoshua,

 

We hope you are doing fine.

 

We have not heard back from you. So we will close this thread. If you need any additional information, submit a new question, as this thread will no longer be monitored.

 

Best regards.

Jean O. 

Intel Customer Support Technician.


0 Kudos
Reply