Wireless
Issues related to Intel® Wireless Adapters and technologies
6286 Discussions

Intel® Wireless-AC 9560 crash with kernel updates

siva3
Beginner
578 Views

i use Ubuntu 20.04. Recently the kernel version got updated, Not sure because of that or not, the wifi was unstable for few days and now it is not working at all. it says no wifi adapter found.
this is what i see from dmesg. This is with kernel 5.4.0-91
[ 520.470502] iwlwifi 0000:00:14.3: WRT: Overriding region id 1
[ 520.470507] iwlwifi 0000:00:14.3: WRT: Overriding region id 2
[ 520.470509] iwlwifi 0000:00:14.3: WRT: Overriding region id 3
[ 520.470511] iwlwifi 0000:00:14.3: WRT: Overriding region id 4
[ 520.470513] iwlwifi 0000:00:14.3: WRT: Overriding region id 6
[ 520.470514] iwlwifi 0000:00:14.3: WRT: Overriding region id 8
[ 520.470516] iwlwifi 0000:00:14.3: WRT: Overriding region id 9
[ 520.470517] iwlwifi 0000:00:14.3: WRT: Overriding region id 10
[ 520.470519] iwlwifi 0000:00:14.3: WRT: Overriding region id 11
[ 520.470521] iwlwifi 0000:00:14.3: WRT: Overriding region id 15
[ 520.470522] iwlwifi 0000:00:14.3: WRT: Overriding region id 16
[ 520.470524] iwlwifi 0000:00:14.3: WRT: Overriding region id 18
[ 520.470525] iwlwifi 0000:00:14.3: WRT: Overriding region id 19
[ 520.470528] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[ 520.470530] iwlwifi 0000:00:14.3: Found debug configuration: 0
[ 520.471025] iwlwifi 0000:00:14.3: loaded firmware version 46.6bf1df06.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 520.480476] iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9560, REV=0x318
[ 520.520868] iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
[ 520.520881] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[ 520.520905] iwlwifi 0000:00:14.3: Fseq Registers:
[ 520.520916] iwlwifi 0000:00:14.3: 0x1822BF3B | FSEQ_ERROR_CODE
[ 520.520928] iwlwifi 0000:00:14.3: 0x00000000 | FSEQ_TOP_INIT_VERSION
[ 520.520940] iwlwifi 0000:00:14.3: 0xF85AFFC0 | FSEQ_CNVIO_INIT_VERSION
[ 520.520951] iwlwifi 0000:00:14.3: 0x0000A384 | FSEQ_OTP_VERSION
[ 520.520963] iwlwifi 0000:00:14.3: 0x9102B8CB | FSEQ_TOP_CONTENT_VERSION
[ 520.520974] iwlwifi 0000:00:14.3: 0x232A9B8F | FSEQ_ALIVE_TOKEN
[ 520.520985] iwlwifi 0000:00:14.3: 0x320F6204 | FSEQ_CNVI_ID
[ 520.520996] iwlwifi 0000:00:14.3: 0xA3D1E534 | FSEQ_CNVR_ID
[ 520.521007] iwlwifi 0000:00:14.3: 0x01000100 | CNVI_AUX_MISC_CHIP
[ 520.521020] iwlwifi 0000:00:14.3: 0x01300202 | CNVR_AUX_MISC_CHIP
[ 520.521033] iwlwifi 0000:00:14.3: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[ 520.521077] iwlwifi 0000:00:14.3: 0xA5A5A5A2 | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[ 520.521185] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x238e
[ 520.521194] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -5
[ 520.533922] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -5

0 Kudos
5 Replies
siva3
Beginner
575 Views

Also tried updating to 5.15.5 kernel, 

Also did reset BIOS.
And when i disabled Bluetooth in BIOS with the new kernel, i observed wifi was stable for around 4 minutes but it crashed later.
Attached the new dmesg logs.

 

siva3
Beginner
575 Views

And after a couple of days with 5.15 kernel, i see this

 

sudo dmesg | grep wifi

[ 14.099660] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[ 14.106894] iwlwifi: No config found for PCI dev 9df0/0000, rev=0x318, rfid=0x0
[ 14.106905] iwlwifi: probe of 0000:00:14.3 failed with error -22

JosueO_Intel
Moderator
555 Views

Hello siva3,


Thank you for posting on the Intel communities. In order to have a better understanding of the issue, please share with us the following information: 


  1. Is this a desktop or a laptop?
  2. Is this the original wireless adapter of the system?
  3. Have you checked the issue with the OEM?
  4. Which driver are you using?


Also, please download and install the Intel System Support Utility (Intel SSU):

https://www.intel.com/content/www/us/en/download/18895/26735/intel-system-support-utility-for-the-li...

Open the application and select "Everything" click on "Scan" to see the system and device information. By default, Intel SSU will take you to the "Summary View". Click on the menu where it says "Summary" to change to "Detailed View".  

Click on "Next", save the report and attach it to your response.


Regards, 


Josue O.  

Intel Customer Support Technician



JosueO_Intel
Moderator
524 Views

Hello siva3


Were you able to check the previous post?  

Let us know if you still need assistance.  


Regards, 


Josue O.  

Intel Customer Support Technician



JosueO_Intel
Moderator
511 Views

Hello siva3


We have not heard back from you, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored. 


Regards, 


Josue O.  

Intel Customer Support Technician



Reply