Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7534 Discussions

Intel Wireless Bluetooth keeps disconnecting and is not functional

LakeofStorms
Beginner
1,908 Views

Hello all,

 

I have run into a problem that I've seen pop up on here before but have not seen a solution other than reinstalling windows which I would very much like to avoid if possible. Starting a few days ago the bluetooth connectivity of my PC stopped, the USB ports started being strange, and the sound of a USB device disconnecting started happening constantly. Low and behold it is the Intel Wireless Bluetooth, and I've run out of tricks to get it to function.

Attached is the SSU report, hopefully it helps figure something out.

I have tried disabling and reenabling the device, uninstalling the device, updating drivers, updating my motherboard specific drivers, updating BIOS, updating windows, rebooting, disconnecting from internet and updating drivers, praying to the patron saint of IT, cursing extensively, and hoping for the best. Nothing has worked.

As I mentioned an additional problem of this has been USB devices have been borderline schizophrenic? Flash drives are not accessible when plugged in unless the device is disabled or uninstalled because it causes the PC to try to update devices attached constantly. USB connected controllers/HIDs are sometimes just non-responsive or lag tremendously. Outside of the sound being annoying every time the computer starts up, the additional problems are making it very difficult to continue work on projects. I really would love some help with this before I reach for the nuclear option of windows 10 reinstall.

 

Thank you to anyone who can help,

J Sander

0 Kudos
3 Replies
n_scott_pearson
Super User
1,900 Views

Intel Wireless Bluetooth, like all Bluetooth solutions, offers a standardized USB device interface. Intel Wireless, on the other hand, utilize a separate PCIe interface. Because the two solutions share the PHY hardware (i.e., wireless transmitters/receivers, 2.4GHz antenna, etc.), it is important with Intel Wireless solutions to install BOTH the Bluetooth and Wireless driver/software packages. Until you install the Intel Wireless Bluetooth package, you will be using the Microsoft generic Bluetooth driver package and this can cause problems.

Now, it may be that you do have the Intel Bluetooth Wireless driver/software package installed, but I cannot tell as no Bluetooth capability is being reported in the the SSU report. This may simply be indicative of the problems you are having, in general, with USB support. This support has to be your first priority for repair.

I believe that this USB problem is indicative of a problem with your motherboard's chipset device support/configuration. You need to ensure that you have installed the chipset INF files necessary for your version of Windows. I found the downloads for these packages here: https://www.gigabyte.com/Motherboard/B450-AORUS-PRO-WIFI-rev-1x/support#support-dl-driver-chipset. You should install the latest Windows 10 versions of the AMD Chipset Driver and AMD APU Driver packages.

Hope this helps,

...S

0 Kudos
LakeofStorms
Beginner
1,883 Views

Hey Scott,

 

I've tried updating and installing everything as described. Updated the packages from the link you gave, and no change. I installed whatever I could find of the Intel specific Wireless Bluetooth and Wireless software/drivers. No change. I think you're correct this is a USB specific problem, and more than that I think it's a problem with AMD USB 3.10 eXtensible Host Controller - 1.10 (microsoft). Disabling or uninstalling this device stops the noise from happening, but obviously doesn't fix the problem. I've tried updating everything I can related to this device as well to no avail. At this point on start up the disconnecting/reconnecting problem for bluetooth exists for a few minutes until the AMD USB device stops functioning and says windows has stopped it because of a problem (code 43). I'm going to be submitting some inquiries with AMD and gigabyte/aorus to see if they can help as well, but I figured I'd update you and any future viewers of the situation and see if you had any further ideas I can try.

If not, thank you for the help thus far at least!

As a secondary question, assuming I can either completely uninstall/deal with the USB specific problems but I can't get bluetooth back, do you think a possible solution would be to purchase a bluetooth dongle type thing to restore that functionality, or is that likely to not help?

 

Thank you,

J

0 Kudos
n_scott_pearson
Super User
1,875 Views

Well, it might help - but only if you can isolate a USB port that is on a hub whose driver is operational. This is an ugly workaround regardless.

Intel, in their NUC products' Technical Product Specification (TPS) documents, does a good job of documenting the architecture of the particular NUC, including good block diagrams. This has helped me to sort out this kind of issue when it happens to the NUCs. I cannot say the same for the (mostly useless) documentation provided by other board/system-level vendors.

Yes, please keep me in the loop if you can get any resolution contacting Gigabyte (I don't hold out much hope of getting anything out of Microsoft),

...S

0 Kudos
Reply