Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JKing12
Beginner
1,400 Views

Loss of 5GHz and intermittent disconnections with the Dual Band AC 3160

Recently, my laptop (Acer Aspire E5-571, Windows 10) stopped being able to detect 5GHz signals from any discoverable, compatible routers. On top of this issue, now whenever I connect to a network on 2.4GHz, I suffer from dropouts of seemingly random intervals and length with no obvious work around. This isn't a router issue, as several devices in the household can maintain connections on both 5 and 2.4GHz, nor is this an issue with Windows as it was working fine for several months after the upgrade to Win10. My Wi-Fi card drivers are at 18.33.3.2 which I believe are the current drivers for my card, so I am at a loss for the solution.

0 Kudos
6 Replies
idata
Community Manager
68 Views

GreeningFields,

 

 

Intel recommends to always use the latest driver provided by the computer manufacturer if this adapter is the one installed by factory. You may find their contact information through this link: http://www.intel.com/content/www/us/en/support/topics/OEMs.html Computer Manufacturer Support Website

 

 

Sometimes, a clean installation of the drivers may resolve this situation. Please, obtain the latest drivers from your computer first and then test your connection. If you notice the situation still persists, you may proceed to installing our generic drivers found in our download center. This is how you can do it:

1. Download and save https://downloadcenter.intel.com/download/26096/Intel-PROSet-Wireless-Software-and-Drivers-for-Windo... Intel® PROSet/Wireless Software and Drivers for Windows® 10 taking into consideration your OS architecture 32 or 64 Bit

2. Go to Control Panel, Programs and Features and Uninstall "Intel® PROSet/Wireless Software", if it is installed. When prompted, choose the option to "Discard settings".

3. In Control Panel, Device Manager, Network Adapters, right click on the Intel® Dual Band Wireless-AC 3160 and Uninstall it. Make sure you mark the option to "Delete the driver software for this device".

4. Reboot the PC or scan for hardware changes, check device manager and if an older driver is detected and installed, repeat the actions to uninstall and delete it as well. Repeat this process until the OS does not allow deleting the driver, or until the controller shows as Unknown Device.

5. Install the Intel® Wireless driver. During the first steps of PROSet/Wireless installation, make sure to customize the installation and install all the 3 driver component.

 

 

6. Once you have done all this, you may want to check the adapter settings. Go to Device Manager >> Network Adapters >> Intel® Dual Band Wireless-AC 3160, right click on it and open Properties.

 

 

7. Once you are in Properties, please select the Advanced tab and change the value for the 802.11n Channel Width for band 2.4 to Auto.

 

 

8. Find and select Preferred Band and check with value it is set to. If possible try Prefer 5.2GHz band and No Preference.

 

 

9. Also, set the value of Transmit Power to 5. Highest and then test your connection.

 

 

Please, let us know as soon as possible.

 

 

Best regards,

 

 

Aleki
JKing12
Beginner
68 Views

I performed a full reinstallation yesterday after stumbling across the same solution for another model from the same family of cards, but today during a routine internal maintenance of my laptop I unplugged and reinserted the chip into the PCI slot it seems to now detect 5G signals (if not from my router) and appears to be more reliable than before. I have updated the Driver Settings to match the suggestions, yet I will keep you informed if the issue reoccurs.

idata
Community Manager
68 Views

GreeningFields,

 

 

Thanks your for taking the time and letting us know that the issue has been resolved. Please, do not hesitate to contacting us should you need any further assistance from us.

 

 

Best regards,

 

 

Aleki
JKing12
Beginner
68 Views

It appears once again that the connection has dropped out, even with the card being reseated and using the recommended driver settings. I am at a loss for solutions short of replacement by this point.

idata
Community Manager
68 Views

GreenigFields,

 

 

Please, try the following:

 

 

1. Go to Control Panel >> Hardware and Sound >> Power Options and set it to High Performance and apply it to default settings.

 

2. Check the Change Plan Settings >> Change Advanced Power Settings >> Wireless Adapter settings >> Power Saving Mode and make sure both On Battery and Plugged In are set to Maximum Performance.

 

3. Check the HT Mode and change it to VHT Mode and test your connection.

 

 

Let us know if these steps helped you.

 

 

Best regards,

 

Aleki

 

idata
Community Manager
68 Views

GreenFields,

 

 

We haven't heard from you in a while so we were wondering if you had the opportunity to try the three steps we have sent you previously. Please let us know as soon as you can.

 

 

Best regards,

 

Aleki
Reply