Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7587 Discussions

Ubuntu not recognizing AX210

Kristofferarl
Beginner
2,967 Views

I have a problem with Ubuntu not recognizing my AX210 module.

 

In the settings, only wired network and Bluetooth are displayed.

No error logs are shown with 

dmesg | grep iwlwifi

 

The following has also been tested:

* Running with versions 22.04 and 22.10.

* Have updated to kernel of version 6.1.x and 5.2.x.

* Installing latest firmware from intel.com

* Removing iwlwifi-ty-a0-gf-a0.pnvm

 

Right now I'm feeling kind of stuck and out of ideas to try.

 

Thanks in advance 

 

/Kristoffer

0 Kudos
11 Replies
DeividA_Intel
Employee
2,939 Views

Hello Kristofferarl,  


  

Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with your Intel® Wi-Fi 6E AX210 (Gig+).   


  

In order to better assist you, please provide the following:  


1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

2. Is this a laptop or desktop computer? 

3. Was the wireless adapter working before?

4. Have you tested the adapter with a different operating system? If so, what was the operating system?

5. Have you checked this issue with Linux support?



Best regards, 

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Kristofferarl
Beginner
2,894 Views

1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?   

This is a custom built computer

 

2. Is this a laptop or desktop computer? 

Desktop

 

3. Was the wireless adapter working before?

The adapter has never worked on Ubutnu for wifi. Bluetooth is working though

 

4. Have you tested the adapter with a different operating system? If so, what was the operating system?

Both wifi and bluetooth works with Windows 10

 

5. Have you checked this issue with Linux support?

No. This feels more firmware hardware related so I checked here first.

Any advice where I can get his kind of support for Linux ?

0 Kudos
DeividA_Intel
Employee
2,878 Views

Hello Kristofferarl, 



Thanks for the confirmation. In order to further investigate this issue I will need the following:


1. Provide the Intel® System Support Utility report for the Linux* Operating System for more details:

2. Run the following commands and send us the outcome:  

  • modinfo iwlwifi > If there is no output, then the module isn’t installed this is the distribution installation issue.  
  • lsmod | grep iwlwifi > If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.  
  • To verify, please type: dmesg | grep iwlwifi > If the result is empty, the driver wasn’t initialized and this is a distribution issue. If there is a result populated, proceed with the next step.   
  • dmesg | grep “no suitable firmware found!” > If the result is not empty, it means you don't have a suitable FW (api mentioned in the dmesg). 
  • Please visit here: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi for supported FW, or here https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.  

8. If the above steps don't work, collect the debug data:  

  • Type: dmesg | grep ASSERT   

If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging to extract dmesg and trace-cmd.  


If the output has value, please collect it from the wiki FW dump too.   


Also, you may find support for your Linux system in the following link: https://www.linux.org/whats-new/posts/4458106/



Regards,  

Deivid A.  

Intel Customer Support Technician 


0 Kudos
Kristofferarl
Beginner
2,861 Views

Thanks for the reply Deivid

 

1. Provide the Intel® System Support Utility report for the Linux* Operating System for more details:

kri-desktop.txt

 

2. Run the following commands and send us the outcome:  

 

modinfo iwlwifi >>> output3.txt

lsmod | grep iwlwifi >>> output2.txt

dmesg | grep firmware  >>> output4.txt

dmesg | grep assert  >>> output5.txt

 

 

0 Kudos
DeividA_Intel
Employee
2,843 Views

Hello Kristofferarl, 



Thanks for the reports and the outcome shared. I will proceed to check the issue internally and post back soon with more details. 


 

Best regards, 

Deivid A.  

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
2,805 Views

Hello Kristofferarl, 



Thanks for your patience. Just to confirm, please perform an update to the latest and stable kernel available.


Please let me know once you have installed the latest and most stable kernel available.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
DeividA_Intel
Employee
2,765 Views

Hello Kristofferarl,  



After checking your thread, I would like to know if you need further assistance. 


If so, please let me know. 


 

Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Kristofferarl
Beginner
2,740 Views

Hi Deivid

 

No this is still an issue and I have not managed to come around it.

 

Currently running kernel version

6.2.1-060201-generic

 

Have also tried 

5.4.0-12.15-generic and others without luck

 

Could you please share your findings from my logs?

 

Thanks!

 

regards,

 

Kristoffer

 

 

0 Kudos
DeividA_Intel
Employee
2,676 Views

Hello Kristofferarl, 



Thanks for the confirmation. I will proceed to continue with the investigation and I get back to you with further details as soon as possible.



Regards,  

Deivid A. 

Intel Customer Support Technician 


0 Kudos
DeividA_Intel
Employee
2,603 Views

Hello Kristofferarl, 



Thanks for your patience. Based on the dmesg log, the WLAN failed to be initialized properly. This could be related to a compatibility issue on this Kri-embedded computer under Linux. 


At this point, I recommend you the following:


1. Consider disabling PCIe ASPM on AX210.

A brief introduction about ASPM can be found here: https://wireless.wiki.kernel.org/en/users/documentation/aspm

- The section 'Enabling ASPM with setpci' provides steps to look for the Link Control Register of the PCIe device, and provides an example to disable ASPM:

# Disables ASPM, enables only L0

sudo setpci -s 00:1c.1 0x50.B=0x40

(Note. The ASPM value will be automatically re-enabled after the system reboot.)

2. If the setpci method doesn't work, please try to update the BIOS to the latest version. Or try to access BIOS and disable settings related to 'PCIe power save' or 'PCIe ASPM (Active State Power Management)'


If the previous steps did not work, the last recommendation would be to check with the computer manufacturer for further investigation.



Please keep in mind that this thread will no longer be monitored by Intel.  


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Kristofferarl
Beginner
2,518 Views

Thanks for the awesome support!

 

I have now been able to figure out what caused the issue.


Apparently Ubuntu does not support when "hot plug" is enabled on the current PCIe bus that the card is connected to. Disabling it solved the issue.

 

On that not its exactly the opposite in Windows10 where i get blue screen when its disabled.

 

Happy Easter!

 

regards,

 

Kristoffer

0 Kudos
Reply