Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
7312 Discussions

Windows 11 Drive missing - Headset W820NB - EDIFIER

llaos
Beginner
4,999 Views

Hi folks.

I'm here to ask for help.

 

Within the previous knowledge I have, I believe I have already exhausted the alternatives I know how to solve this problem. And I couldn't, that's why I'm here. I count on the support of those who can dedicate a little of their time to help with this situation.

 

I purchased the EDIFIER W820NB headset/headphone, and since then I have had difficulty finding the correct sound/bluetooh drive for it in Windows 11.

However, on my android smartphone and windows 10, the necessary drivers were found automatically by win10 and respectively on the smartphone...

 

However, on windows 11 it doesn't work. And what I miss is the DRIVE STEREO for this device, as windows 10 found automatically... I already tried updating with windows update, I already searched for drive manually, and the ones I found, didn't work. I tried to extract the drive from windows 10 and use in windows 11, but without success.

 

In smartohone and win10, works perfectly... Both headset and headphone, perfect audios, both input and output. As I expected it to be.

But in windows 11, it won't.

I will attach a print of the drive installed on win10 and win11. In case it helps to have a north of how I can solve this issue.

Thanks

0 Kudos
4 Replies
n_scott_pearson
Super User
4,993 Views

I suggest you do a clean reinstall of your Wireless/Bluetooth drivers. Here is my process for doing so (using Intel's AX200 module as example):

  1. If you haven't already, download - but do not install just yet - the desired Bluetooth and Wireless driver packages for your adapter. Here are the current links for downloading these drivers: Wireless: https://www.intel.com/content/www/us/en/download/19351 and Bluetooth: https://www.intel.com/content/www/us/en/download/18649
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From the Apps & Features applet, check for instances of Intel PROSet/Wireless Software and Intel Wireless Bluetooth. If none, skip to Step 6.
  4. Uninstall each instance of Intel PROSet/Wireless Software and/or Intel Wireless Bluetooth that is present. When prompted, choose to "Discard Settings".
  5. Manually reboot your computer, keeping Internet access disabled throughout.
  6. From the Device Manager applet, check the Network Adapters section for an entry for Intel Wi-Fi 6 AX200 and check the Bluetooth section for an entry for Intel Wireless Bluetooth that has an intel driver associated with it. If neither is the case, go to Step 10.
  7. Right click on the entry for Intel Wi-Fi 6 AX200 and uninstall it, choosing to (checkmark) Delete the driver software for this device.
  8. Right click on the entry for Intel Wireless Bluetooth and open its properties. If it has an Intel driver associated with it, then uninstall it, choosing to (checkmark) Delete the driver software for this device.
  9. Go to Step 5.
  10. (Optional but recommended) Clean out all temporary files using the Windows Clean Disk tool. Ensure you have enabled cleaning of System Files. I recommend that you then checkmark all categories offered, even if no files currently in this category (so it leaves it set up for next invocation).
  11. (Optional but recommended) Clear each of your browsers' cache.
  12. Install the downloaded Bluetooth driver package (my rule: always install Bluetooth first).
  13. Install the downloaded Wireless driver package.
  14. Manually shutdown and reboot your computer.
  15. Reenable Internet access. Restore Ethernet cable and/or reenable wireless.
  16. Test.

If this doesn't work, come back and let us know. We'll want to know what Intel Wireless module you have in your system. It would also save time if you download and run the Intel System Support Utility for Windows. When you start the tool, select Everything and then click on Scan. Once it completes the scan process, click on Next and then Save. Pick a name for the text file to create and click on Save to create it. You can then close the app. Finally, open a response post here and then, using the Drag and drop here or browse files to attach dialog (below the edit box for the body of your response post), upload and attach this text file to the response post.

Hope this helps,

...S

0 Kudos
llaos
Beginner
4,976 Views

Hi Scott,

Thank you for your time, to bring a possible solution to the case I brought.

 

It didn't work as expected, unfortunately. I may have done something wrong in the process too, as the drivers after manually uninstalling and disconnecting from the internet, reinstalled by themselves when I restarted the laptop.

I cleaned the temporary files as you suggested, but I believe there is some folder in the system where bkp of the drive intall is. That might be why they automatically reinstalled. But I don't know which folder and what I could delete in it.

I ran the Intel SSU. See print

0 Kudos
Michael7771
Beginner
2,480 Views

Hello, 

I followed the instructions closely for this attempted fix to the same issue as the original inquiry. I thought you might find it interesting that after these procedures; the device mgr still doesn't show the 2 new Intel files that were installed. Current version is WIN 11pro 23H2. Same issues on 22H2. My 9yo machine running 22H2 has no bluetooth issues. I'm guessing some setting is wrong or unchecked in this brand new desktop. A usb bluetooth that was working on the old machine is also not recognized, yet the system makes the usual beep when plugged into the port. I will attempt to include the SSU file.

Thank you

0 Kudos
n_scott_pearson
Super User
4,970 Views

Then you didn't do every step as detailed. See Step 2, where you were supposed to disable internet access and not enable it again until told to. Obviously, you either ignored this instruction or didn't do it in a way that would survive rebooting).

...S

0 Kudos
Reply