Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7589 Discussions

intel 8260 AP mode for ftm respondor

dreamstar
Beginner
2,247 Views

Hello!

I have been working and testing FTM function using Iwlwifi on intel 8260.

Now, I used below
* iwlwifi driver - core30 backporting, intel firmware version 31.
and iw 4.9 version (already i patched patch -p1 < bef149ad0c1b8c8f.txt)

I have tested AP mode on 2.4GHz (on devices driven by iwlmvm), it is OK.

But, I cannot use 5Ghz band as FTM Respondor.

 

How can I use 5Ghz band with AP mode?

 

 

 

0 Kudos
1 Solution
Jocelyn_Intel
Employee
2,230 Views

Hello, @dreamstar

 

Thank you for posting on the Intel® communities. I will gladly assist you here. 

 

Please provide us with the basic information about your OS: 

  1. OS name (e.g. Ubuntu 22.04. LTS) 
  2. Linux/kernel version 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


View solution in original post

0 Kudos
10 Replies
Jocelyn_Intel
Employee
2,231 Views

Hello, @dreamstar

 

Thank you for posting on the Intel® communities. I will gladly assist you here. 

 

Please provide us with the basic information about your OS: 

  1. OS name (e.g. Ubuntu 22.04. LTS) 
  2. Linux/kernel version 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
dreamstar
Beginner
2,216 Views

Hello !

 

-Basic information

* 0S : Debian GNU/Linux 9

* Kernel : Linux version 4.4.194

Enable 802.11mc FTM on Intel 8260

iwlwifi :   switch to release/LinuxCore30

intel fw : iwlwifi-8000C-31.ucode

wget https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git/tree/iwlwifi-8000C-31.ucode

 (refer to https://github.com/HappyZ/iw_intel8260_localization/wiki/Enable-802.11mc-FTM-on-Intel-8260)

 

dreamstar_0-1678417689657.png

 

Thank you for your support.

0 Kudos
dreamstar
Beginner
2,215 Views

additional info.

 

I proceeded by referring to the following information.

refer to https://www.winlab.rutgers.edu/~gruteser/projects/ftm/Setups.htm

 

0 Kudos
DeividA_Intel
Employee
2,178 Views

Hello dreamstar, 



Thanks for your response. I noticed that you marked the response from Jocelyn_Intel as a solution, I would like to confirm if the issue is fixed.


Please let me know if you need further support.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Jocelyn_Intel
Employee
2,153 Views

Hello, @dreamstar

 

Thank you for the information provided. 

 

I will proceed to do some research, as soon as I have updates, I will post them here. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Jocelyn_Intel
Employee
2,139 Views

Hello, @dreamstar


Thank you for your time.

 

We recommend you upgrading to the latest and stable Kernel version and test it again. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
dreamstar
Beginner
2,112 Views

Hello!

 

As I know latest kernel version is not support FTM Function.

I want to use 802.mc FTM Function.

So I proceeded by referring to the following information.

refer to https://www.winlab.rutgers.edu/~gruteser/projects/ftm/Setups.htm

 

* FTM Intel firmware 

iwlwifi-8000C-31.ucode

Is this firmware 5Ghz available?

 

* FTM iwlwifi driver

https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git -b release/LinuxCore30

Is this driver can support 5Ghz AP mode?

 

I used hostapd.conf

# cat /hostapd.conf
driver=nl80211
interface=wlp1s0
hw_mode=a
channel=36
#ieee80211n=1
#ieee80211ac=1
#ieee80211d=1
#ht_capab=[HT40+]
#vht_oper_chwidth=0
#vht_oper_centr_freq_seg0_idx=38
#hw_mode=g
#channel=1
wmm_enabled=1
ssid=ftm_respondor
ftm_responder=1
ftm_initiator=1

 

-> hw_mode=a : 5ghz

and then, I executed hostapd below

#hostapd -d /hostapd.conf -B

 

but can't excuted as 5ghz AP mode.

please check attached fail log.

I don't know why 5ghz mode don't operate.

 

 

 

0 Kudos
Jocelyn_Intel
Employee
2,100 Views

Hello, @dreamstar

 

I will proceed to do research about that, as soon as I have updates, I will post them here. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
dreamstar
Beginner
2,080 Views

Hello!

I have a additional question.

How can I change regulatory domain (for 5g band use)?

I think that no IR flag is some problem in hostapd 5ghz execution fail log.txt

nl80211: Regulatory information - country=00
nl80211: 2402-2472 @ 40 MHz 20 mBm
nl80211: 2457-2482 @ 20 MHz 20 mBm (no IR)
nl80211: 2474-2494 @ 20 MHz 20 mBm (no OFDM) (no IR)
nl80211: 5170-5250 @ 80 MHz 20 mBm (no IR)
nl80211: 5250-5330 @ 80 MHz 20 mBm (no IR)
nl80211: 5490-5730 @ 160 MHz 20 mBm (no IR)
nl80211: 5735-6235 @ 80 MHz 20 mBm (no IR)
nl80211: 57240-63720 @ 2160 MHz 0 mBm

 so, I tried below

# iw reg set US

# iw reg get

but Not changed! like below.

 

global
country 00: DFS-UNSET
(2402 - 2472 @ 40), (6, 20), (N/A)
(2457 - 2482 @ 20), (6, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(2474 - 2494 @ 20), (6, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 80), (6, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(5250 - 5330 @ 80), (6, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (6, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)

phy#0 (self-managed)
country 00: DFS-UNSET

 

I tested regdomain change with another board that used realtek wireless module.

(In same kernel version. same wireless kernel stack, same iw version)

--> It changed OK. and 5G AP mode OK (test with same hostapd version)

 

and also I tested with modprobe option (lar_disable=1, 11n_disable)

#modprobe iwlwifi lar_disable=1

 But it doesn't work 5G AP mode either

 

 

 

 

0 Kudos
Jocelyn_Intel
Employee
2,056 Views

Hello, @dreamstar

 

Thank you for your time. 

 

You can consider trying the iw 5.9 version on the Wireless-AC 8260. Also, we suggest you to try FTM on newer systems using newer wireless products, such as Intel AX200. 

 

Here is additional FTM information: 

http://www.winlab.rutgers.edu/~gruteser/projects/ftm/Setups.html 

 

In any case, please note our wireless product support is mainly a STA/ client solution on PCs. For more queries or details about designing FTM or Wi-Fi AP mode, talk with your Intel representative directly (Intel FAE).  

  

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
Reply