Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6024 Discussions

iwlwifi cannot find suitable firmware (AX201 on Ubuntu 20.04)

Jinmin
Beginner
2,477 Views

I recently bought new Samsung laptop (NT750XDZ-AD51S) having AX201 wifi controller.

 

When I checked dmesg related iwlwifi, I seems iwlwifi cannot find suitable firmware.

-----------------------------------

$sudo dmesg | grep iwlwifi

[ 4.519577] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[ 4.523133] iwlwifi 0000:00:14.3: Direct firmware load for (efault)128.ucode failed with error -2
[ 4.523450] iwlwifi 0000:00:14.3: Direct firmware load for (efault)127.ucode failed with error -2
[ 4.523777] iwlwifi 0000:00:14.3: Direct firmware load for (efault)126.ucode failed with error -2
....
[ 4.526583] iwlwifi 0000:00:14.3: Direct firmware load for (efault)3.ucode failed with error -2
[ 4.526605] iwlwifi 0000:00:14.3: Direct firmware load for (efault)2.ucode failed with error -2
[ 4.526625] iwlwifi 0000:00:14.3: Direct firmware load for (efault)1.ucode failed with error -2
[ 4.526648] iwlwifi 0000:00:14.3: Direct firmware load for (efault)0.ucode failed with error -2
[ 4.526650] iwlwifi 0000:00:14.3: no suitable firmware found!
[ 4.526654] iwlwifi 0000:00:14.3: minimum version required: (efault)0
[ 4.526657] iwlwifi 0000:00:14.3: maximum version supported: (efault)128
[ 4.526659] iwlwifi 0000:00:14.3: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

------------------

 

 

When I check module info of installed iwlwifi with modinfo command, it seems the iwlwifi requires 56 version firmware as following. 

==========================

$ modinfo iwlwifi | grep Qu
firmware: iwlwifi-QuQnj-b0-jf-b0-56.ucode
firmware: iwlwifi-QuZ-a0-jf-b0-56.ucode
firmware: iwlwifi-QuZ-a0-hr-b0-56.ucode
firmware: iwlwifi-Qu-b0-jf-b0-56.ucode
firmware: iwlwifi-Qu-c0-hr-b0-56.ucode
firmware: iwlwifi-QuQnj-b0-hr-b0-56.ucode
firmware: iwlwifi-Qu-b0-hr-b0-56.ucode

 

But, when I checked the installed firmware in my laptop, there are lower versioned firmware than 56.

===========================

$ ls -l /lib/firmware/iwlwifi-Qu*
-rw-r--r-- 1 root root 1106228 6월 12 00:19 /lib/firmware/iwlwifi-Qu-b0-hr-b0-48.ucode
-rw-r--r-- 1 root root 1223144 6월 12 00:19 /lib/firmware/iwlwifi-Qu-b0-hr-b0-55.ucode
-rw-r--r-- 1 root root 1052796 6월 12 00:19 /lib/firmware/iwlwifi-Qu-b0-jf-b0-48.ucode
-rw-r--r-- 1 root root 1163672 6월 12 00:19 /lib/firmware/iwlwifi-Qu-b0-jf-b0-55.ucode
-rw-r--r-- 1 root root 1106248 6월 12 00:19 /lib/firmware/iwlwifi-Qu-c0-hr-b0-48.ucode
-rw-r--r-- 1 root root 1223160 6월 12 00:19 /lib/firmware/iwlwifi-Qu-c0-hr-b0-55.ucode
-rw-r--r-- 1 root root 1052816 6월 12 00:19 /lib/firmware/iwlwifi-Qu-c0-jf-b0-48.ucode
-rw-r--r-- 1 root root 1163688 6월 12 00:19 /lib/firmware/iwlwifi-Qu-c0-jf-b0-55.ucode
-rw-r--r-- 1 root root 1105668 6월 12 00:19 /lib/firmware/iwlwifi-QuZ-a0-hr-b0-48.ucode
-rw-r--r-- 1 root root 1103952 6월 12 00:19 /lib/firmware/iwlwifi-QuZ-a0-hr-b0-50.ucode
-rw-r--r-- 1 root root 1223140 6월 12 00:19 /lib/firmware/iwlwifi-QuZ-a0-hr-b0-55.ucode
-rw-r--r-- 1 root root 1052608 6월 12 00:19 /lib/firmware/iwlwifi-QuZ-a0-jf-b0-48.ucode
-rw-r--r-- 1 root root 1163668 6월 12 00:19 /lib/firmware/iwlwifi-QuZ-a0-jf-b0-55.ucode

 

But, I cannot find the 56 version firmware even  in the latest firmwares repo -

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/

 

It seems that if I install suitable firmware then, this issue can be solved easily.

But, I cannot find the suitable firmware.

 

 

Just for your information. my kernel version is 5.8.0-59-generic.

$ uname -r
5.8.0-59-generic

 

$ lshw -c network
*-network UNCLAIMED
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
version: 20
width: 64 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: iomemory:600-5ff memory:6001144000-6001147fff

 

0 Kudos
3 Replies
sorandy
Novice
2,450 Views
Hi Jinmin,

As https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html
suggests, you'd need to install the one for AX201(second one from the top) and that seems to match the one that is demanded from the output you showed.

Install it and copy iwlwifi-*.ucode to /lib/firmware. Then run the following command on your terminal,
# sudo modprobe iwlwifi
, and reboot. Give it a try and I hope it helps.

Best,
So

Jinmin
Beginner
2,438 Views

Thank you for your explanation. 

 

I already have more recent firmwares for AX201 than those in "https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html" since I installed latest ubuntu 20.04 and updated recent patches for Ubuntu 20.04. 

 

As I mentioned in original message, I already have iwlwifi-Qu*-48.ucode and iwlwifi-*-Qu55.ucode. 

Do I have to remove those existing firmwares and install  iwlwifi-Qu*-48.ucode  from "https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html ?

 

 

sorandy
Novice
2,432 Views

Hi Jinmin,

 

Sorry for misreading your post. I now see what you are saying and you are right on finding it nowhere on the Internet.

I cannot think of any good suggestion at this moment, but changing the kernel version to one that has a required *.ucode in the linux-firmware git repo might help. I am sorry that I cannot save you out of this headache but do hope that anyone with a better idea continue this thread.


Best of luck,

So

 

 

Reply