oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.
1387 Discussions

oneAPI 2022.3 Windows: disable IDE integration to avoid failure

scivision
New Contributor I
1,853 Views

As with oneAPI 2022.2 on Windows, to avoid failure of the installer (on Base or HPC) disable IDE integration. This was both with Visual Studio 2022.

Labels (1)
0 Kudos
6 Replies
ArpanB_Intel
Moderator
1,816 Views

Hi Michael, could you specify the builds of Visual Studio 2022 that you have installed on your system? Also, are you using Windows 10 or Windows 11? Please confirm the OS build as well.


We would like to know.


0 Kudos
scivision
New Contributor I
1,810 Views

I only have one version of Visual Studio and oneAPI installed, all default locations.
I didn't screenshot the error I got, but I think it was just the same error in the same way as the prior oneAPI release, where as I recall, the oneAPI forum advice was not to install IDE integrations as VS 2022 had a new API.


 

**********************************************************************
** Visual Studio 2022 Developer Command Prompt v17.3.5
** Copyright (c) 2022 Microsoft Corporation
**********************************************************************
[vcvarsall.bat] Environment initialized for: 'x64'

 > cl
Microsoft (R) C/C++ Optimizing Compiler Version 19.33.31630 for x64



Windows 11 22H2 OS Build 22621.521



:: initializing oneAPI environment...
Initializing Visual Studio command-line environment...
Visual Studio version 17.3.5 environment configured.
"C:\Program Files\Microsoft Visual Studio\2022\Community\"
Visual Studio command-line environment initialized for: 'x64'
: compiler -- latest
: debugger -- latest
: dev-utilities -- latest
: mkl -- latest
: mpi -- latest
: tbb -- latest
:: oneAPI environment initialized ::

> icx
Intel(R) oneAPI DPC++/C++ Compiler for applications running on Intel(R) 64, Version 2022.2.0 Build 20220730

 

0 Kudos
ArpanB_Intel
Moderator
1,807 Views

Michael, please note that oneAPI compiler 2022.3 is compatible with builds VS2022 17.2.3 and VS2022 17.2.6 (limited testing). If you have any other build of VS 2022, we suggest you to uninstall them.


For information regarding the compatibility, visit here: https://www.intel.com/content/www/us/en/developer/articles/reference-implementation/intel-compilers-compatibility-with-microsoft-visual-studio-and-xcode.html


0 Kudos
scivision
New Contributor I
1,801 Views
Thanks. A nice addition would be if the installer would warn about incompatible visual studio minor release version as most users will have a newer visual studio release and like me neglect to read the docs ha ha. Or at least give an error that says what the incompatibility is-- the current error for incompatible IDE is not at all related to that.
0 Kudos
ArpanB_Intel
Moderator
1,736 Views

Michael, thank you for sharing your valuable feedback with us.


We will pass this feedback on through our communication channels for further considerations regarding the improvement of our product and it's future releases.


Having said that, please let us know if you have any further queries on the same.


0 Kudos
ArpanB_Intel
Moderator
1,694 Views

Michael, unfortunately we were unable to hear back from you.


If you have any further queries, please post a new question as this thread will no longer be monitored by Intel®.


0 Kudos
Reply