Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jack_S_
Beginner
70 Views

ADVISOR_ANNOTATE is not recognized during compilation

Hello to the Advisor team,

I'm compiling and linking my code as following :

      COMPILE='ifort -g -O2 -I$/opt/intel/advisor_xe_2015/include/intel64'

     $COMPILE -c Parcel_Update_8_8.F90

     $COMPILE -o Parcel_Model_Advisor.x *.o -lm -L$/opt/intel/advisor_xe_2015/lib64 -ladvisor

     rm *.o

In the compilation log file I'm getting an error : ''error #7002: Error in opening the compiled module file.  Check INCLUDE paths.   [ADVISOR_ANNOTATE] use advisor_annotate  !  Add to each module that contains Intel Advisor annotations ''

I have inserted the annotations to one of the subroutines in the code as indicated by the Advisor tool :

       use advisor_annotate  !  Add to each module that contains Intel Advisor annotations

      call annotate_site_begin( "MySite1" )  !  Place before the loop control statement to begin a parallel code region
                                             ! (parallel site).

      call annotate_iteration_task( "MyTask1" )  !  Place at the start of loop body. This annotation identifies an entire body
                                                 ! as a task

     call annotate_site_end  !  End the parallel code region, after task execution completes

 

What should I do for the ADVISOR_ANNOTATE module to be recognized during compilation ?

 Thanks in advance,

Jack.

 

 

 

 

0 Kudos
1 Reply
Robert_L_Intel1
Employee
70 Views

Hi Jack - I think this might be a problem with your use of variable names and actual path locations.  

When I do a quick look, here is what I see WRT Intel® Advisor XE paths on Linux:

advisor_xe -> /opt/intel//advisor_xe_2015.1.10.380555/
advisor_xe_2015 -> /opt/intel//advisor_xe_2015.1.10.380555/
advisor_xe_2015.1.10.380555/

The best thing I think would be for you to use the environment variables after having setup the environment with the advixe-vars.sh script.

Here are some resources.

Setting up your command line environment:
https://software.intel.com/en-us/node/527378

Build Settings:
https://software.intel.com/en-us/node/527410

Could you please setup your environment as prescribed above and try again, using the variables?  Please capture the output and post the results.

If you prefer, for secure communications with the VTune Amplifier XE support staff, you can always submit your problem to Intel(R) Premier Support.

https://premier.intel.com/
 
It's free, secure technical support.

 

Reply