Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Advisor XE 2016 Analysis fail when loading managed .NET assembly

Alain_M_
Beginner
123 Views

We have a C++/C# software that we profile with Advisor XE 2016.

During profiling session, when we load a .NET assembly, Advisor stops "Check Dependencies" analysis with the message :

"Failed to load .NET profiler, please reinstall Advisor".

The problem is that I want to profile only C++ native modules, not the C# ones ... and I don't see a .NET profiler in Advisor.

0 Kudos
7 Replies
Kirill_R_Intel
Employee
123 Views

Hello,

Try to change "managed code profiling mode" in Advisor project properties to "native", to disable .NET profiling. 

Regards,
Kirill

Kirill_R_Intel
Employee
123 Views

If native mode doesn't help, would you be able to provide your application executable, so that I can reproduce the problem?

Alain_M_
Beginner
123 Views

Hello,

Native mode doesn't help.

As our application is very big, we cannot provide it to you. I will try to reproduce the problem with a small sample including a C++/CLI assembly.

Regards.

Alain.

 

Alain_M_
Beginner
123 Views

Hello,

I have successfully reproduced the problem with a main exe module in native C++ and a C++/CLI DLL.

I have joined the VS 2012 solution to the post. I use .NET Framerwork 4.0.

When Advisor (Check Dependencies) or even Inspector (Thread and Memory Profiling) try to load the managed DLL, the profiler is crashing.

 

Alain_M_
Beginner
123 Views

I just wanted to precise that the crash occurs in Release mode, not in Debug mode.

Regards.

Alain.

Kirill_R_Intel
Employee
123 Views

Thank you Alain for the reproducer! I see the problem and submitted a bug tracker to development team.

Kirill_R_Intel
Employee
123 Views

Alain, this bug was fixed in Intel Inspector 2017, that should be released in August-September. Thank you for reporting the issue!

Reply