Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4682 Discussions

Advisor not loaded correctly in Visual Studio 2010

New Contributor I

I have problems using Advisor on my computer. After I open a Fortran solution, I get a message "The 'Intel Advisor XE 2013' package did not load correctly". If I click "Yes" to continue to show this error, it appear 2-3 times before the solution is opened and parsing files is finished. The solution then opens successfully, but Advisor toolbar icons are grayed and Advisor cannot be used. The same message is displayed if I select Help - About Visual Studio in the Visual Studio main menu.

I am running Windows 7 Professional 64-bit, Service Pack 1, with latest updates.

I use Microsoft Visual Studio 2010 Professional, Service Pack 1, with latest updates. After installing Visual Studio, I added the plugin VisualHG (Mercurial Source Control) and Visual Studio Color Theme Editor (I changed the color scheme from the default one to Windows Aero).

Advisor is XE 2013, Update 5.

I uninstalled Advisor and everything was OK. After I installed it again (and I always restart my computer even though I don't think it is necessary), the problem is back. I tried running Visual Studio as administrator, but this did not help.

I followed the advice given in the error message and let Visual Studio log its activity. A part of the output, showing the location where the problem occurs, is attached.

What else could I try to make Advisor work?

0 Kudos
6 Replies

This is a new one on me, I am going to contact the installation engineer and see if he will respond to this directly.


Hello Jirina,

Thank you for the detailed post - I appreciate your taking the time to triage it.

I am not the installation engineer that Holly refers to in the post above but I was able to follow up on your request. To reproduce this issue at our end, can you please share

  1. Exact versions (Update #) of Intel(R) Parallel Studio XE components installed (namely, Intel(R) VTune(TM) Amplifier XE, Intel(R) Inspector XE and any additional components like Intel(R) Composer XE). You can obtain this information from the Microsoft* Visual Studio's "Help->About Microsoft Visual Studio" pulldown menu.
  2. Please provide the following file in its entiriety: C:\Users\Jiri Brada\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml - you can email it to me at ravi DOT vemuri AT intel DOT com
  3. Are you able to run Intel(R) Inspector XE or Intel(R) VTune(TM) Amplifier XE? Are the Visual Studio menu entries for those or any other Intel(R) Parallel Studio XE components not greyed out?
  4. If it is not too much trouble, would you kindly try uninstalling each of the components Intel(R) Inspector XE or Intel(R) VTune(TM) Amplifier XE to see whether Advisor issue is still reproducible.

I'd be glad to request our Intel(R) Advisor XE engineering team to help triage this issue if you would rather not triage it youself. PLease do not hesitate to let us know!

Sorry for the inconvenience that this issue may be causing you.

Thank you.

New Contributor I

1. Beside Advisor, I have these products installed:

Intel(R) Visual Fortran Composer XE 2013 SP1 Update 1 Integration for Microsoft Visual Studio* 2010, 14.0.0074.2010

Intel® Inspector XE 2013 Update 9, (build 328075)

Intel® VTune™ Amplifier XE 2013 Update 15, (build 328102)

2. I am attaching the full Activity Log to this post - there is nothing confidential in it.

3. The only icons grayed out are those for Advisor. Inspector and VTune Amplifier icons are just fine and both products work well.

4. I will try uninstalling Inspector and VTune Amplifier, keep just Composer and see what happens if I install just Advisor. I will do this later.

New Contributor I

I uninstalled Advisor, VTune Amplifier and Inspector in this order and installed all of them again, in the same order, starting with Advisor. All of them work fine now.

The only explanation seems that they were bad sectors on the hard disk and one of them was use by a file belonging to Advisor.

So, my original message can be ignored. I would like to thank you for your effort to resolve this "problem".


Glad to hear it works now!

Black Belt

"The only explanation seems that they were bad sectors on the hard disk and one of them was use by a file belonging to Advisor"

It could have been also AV software or registry failure.