Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cole_b_
Beginner
89 Views

Bandwidth Microarchitecture Analysis is not collecting data.

I am trying to familiarize myself with VTune Amplifier. I am attempting to run the "Bandwidth" test under "Microarchitecture Analysis". When I run it, the summary tab shows the "Elapsed Time" and the "Collection and Platform Info" section, but there is no "Average Bandwidth" section. When I go to the Bottom-up tab, the Bandwidth graph is empty. I assume it is not collecting memory data correctly.

This is running on Ubuntu 14.04 with the Silvermont Celeron J1900 chip. Is it because this cpu is not supported? Or am I misunderstanding what this test is supposed to do. 

Thanks

0 Kudos
9 Replies
David_A_Intel1
Employee
89 Views

Hi cole:

If the tool is not displaying a warning when you select the analysis type, it should be supported on the processor.

Questions: how long is the "elapsed time" reported by VTune Amplifier?  What version of VTune Amplifier are you using (output of 'amplxe-cl -version')?

cole_b_
Beginner
89 Views

The version is VTune Amplifier XE 2015 Update 4.1 (Build 412820). The elapsed time is 58.564s with a CPU time of 51.892s. If it matters, the hotspot test works as expected.

David_A_Intel1
Employee
89 Views

okay, that release should support what you are trying to do.  However, let's verify that the VTune Amplifier drivers are loaded.  As root/sudo, cd to <install-dir>/sepdk/src and execute the command './insmod-sep3 -q'.

cole_b_
Beginner
89 Views

I ran the command both as sudo and default user. Both returned:

pax driver is loaded and owned by group "vtune" with file permissions "666".

sep3_15 driver is loaded and owned by group "vtune" with file permissions "666".

vtsspp driver is loaded and owned by group "vtune" with file permissions "666".

 

89 Views

Hello Cole B.,

Can you please verify several additional things, it will allow to figure out whether uncore events can be collected or not on your system:

From <vtune install dir>/bin64/ run:

1. >./sep -pmu-types

    You should see "sa" in the output

2. >./sep -el sa

    You should see "UNC_VISA_Memory_DDR_BW" in the outputed list

3. >./sep -start -d 10 -ec "UNC_VISA_Memory_DDR_BW"

     The collection should generate *.tb6 file

4. > ./amplxe-cl -import ./<the tb6 file>

    As result you should see a report with Uncore events collected. Something like below:

Uncore Event summary
--------------------
Hardware Event Type                        Hardware Event Count:Self
-----------------------------------------  -------------------------
UNC_VISA_Memory_DDR_BW.DDR_Chan0_Read32B                          57
UNC_VISA_Memory_DDR_BW.DDR_Chan0_Read64B                     5220544
UNC_VISA_Memory_DDR_BW.DDR_Chan0_Write32B                        234
UNC_VISA_Memory_DDR_BW.DDR_Chan0_Write64B                     822748
UNC_VISA_Memory_DDR_BW.DDR_Chan1_Read32B                           0
UNC_VISA_Memory_DDR_BW.DDR_Chan1_Read64B                           0
UNC_VISA_Memory_DDR_BW.DDR_Chan1_Write32B                          0
UNC_VISA_Memory_DDR_BW.DDR_Chan1_Write64B                          0

 

 

 

 

Please provide output from each of 1-4 commands below.

Regards, Katya

 

cole_b_
Beginner
89 Views

I attached the outputs because the formatting was too weird otherwise. FYI, for step 3 and 4, I had to use sudo for the command to work. Step 4 also produced a lot of the "Cannot locate debugging symbols for file '...'" warnings, but I've read that is normal. It seems I am getting all 0's in the "Hardware Event Count:Self" Column.

 

 

89 Views

Hello,

Can you please make sure your system BIOS is configured to PerfMode as specified in this article:

https://software.intel.com/en-us/articles/SLM-SoC-uncore-performance-monitoring-guide

Enabling uncore monitoring

In order to sample uncore events, the feature must be enabled by BIOS/FW.  Indicators that the FW is not configured for uncore monitoring are:

  1. All events counts are zero
  2. System agent event counts correctly but all memory controller event counts are zero

On a platform enabled with BIOS menus, there may be a menu option to change "PDM/DFX" setting.  The desired setting is “PerfMode”.  Otherwise you must acquire a FW version with uncore monitoring enabled from your firmware provider.

If your BIOS does expose the PerfMode option, then it will likely be under a "Debug Configuration" menu 

Regards,

Katya

cole_b_
Beginner
89 Views

It appears that his setting is not available in my BIOS. I likely won't be able to get the right firmware, so I will look elsewhere for this type of benchmarking. Are the other tests that produce results still accurate without this setting? Is it specific to the Memory Bandwidth tests?

89 Views

Hello Cole B.

It's specific to Memory Bandwidth, as on Silvermont-based platforms it requires uncore monitoring enabled.

Algorithm analsysis and core profiling should work. Let us know if you see other issues.

Regards, Katya