Community
cancel
Showing results for 
Search instead for 
Did you mean: 
m_faulkner
Beginner
124 Views

Bus Utilization on Dual Processor Xeon

Hey all,

I'm calcuating the bus utilization on a dual processor xeon machine (so i have 8 cores in total).

However, when i come to calcuate the Bus utilisation i get values of up to 200% (I'm assuming it's %)

I'm recorded the metrics as referenes in the vtune reference, i.e. BUS_TRANS_ANY.ALL_AGENTS and CPU_CLK_UNHALTED.BUS.

Does this seem correct? To me this seems wrong.

Any pointers will be great.

Thanks
0 Kudos
5 Replies
TimP
Black Belt
124 Views

The CPU to bus clock speed ratio factors into this. VTune asks you to enter the CPU speed, but I think it guesses the bus speed. Also, if your formula uses a single socket bus capacity rating, that would be wrong for dual socket with balanced usage. If you get all the numbers right, you are unlikely to achieve even 80%.
m_faulkner
Beginner
124 Views

Quoting - tim18
The CPU to bus clock speed ratio factors into this. VTune asks you to enter the CPU speed, but I think it guesses the bus speed. Also, if your formula uses a single socket bus capacity rating, that would be wrong for dual socket with balanced usage. If you get all the numbers right, you are unlikely to achieve even 80%.

Thanks for the reply.

How does vtune factor in the CPU to bus speed ratio? I'd like to understand the exact forumlae used.
TimP
Black Belt
124 Views

Quoting - m.faulkner
How does vtune factor in the CPU to bus speed ratio? I'd like to understand the exact forumlae used.
Sorry, I may be thinking of some older machine. There surely is a lack of searchable references on this.
m_faulkner
Beginner
124 Views

Quoting - tim18
Sorry, I may be thinking of some older machine. There surely is a lack of searchable references on this.
So we now think that the bus utilisation does use the ratio of bus speed / cpu speed? If so then i still don't understand why when i record the above metric i get a % utilisation of around 200%
m_faulkner
Beginner
124 Views

Quoting - m.faulkner
So we now think that the bus utilisation does use the ratio of bus speed / cpu speed? If so then i still don't understand why when i record the above metric i get a % utilisation of around 200%
Having looked in to this, i'm now wondering if it has to do with the fact that i'm recording on all my cores? Therefore having a figure which (because i've got 8 cores) is x8 greater than it should be?

Any one any hints as to why i would have the BUS UTILIZATION > 100% (using the forumlae from the vtune docs)
Reply