Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Jonathan_Moore
Beginner
59 Views

Call Graph : "Copying instrumented files failed. All files will be restored"

Hi,

Has anyone come across the above error reported in a modal dialog box when trying to run a callgraph activity, or have ideas on how to troubleshoot it?

I am using Intel VTune Performance Analyzer 9.1 Build:210

The application being profiled is straight C++, compiled with Visual Studio 2005.

The main Output window reports no errors

"Tue Oct 12 15:31:40 2010 Static instrumentation started
Tue Oct 12 15:31:44 2010 All functions instrumentation of module "c:\\p4ws\\depot\\qa\\fi\\fi_main.br\\project\\qaframework\\bin\\release8\\qafinitedifferencesolvers_210800_01.qag" was successful.
Tue Oct 12 15:31:45 2010 Minimal instrumentation of module "c:\\winnt\\system32\\kernel32.dll" was successful.
Tue Oct 12 15:31:46 2010 Minimal instrumentation of module "c:\\winnt\\winsxs\\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4053_x-ww_e6967989\\msvcr80.dll" was successful.
Tue Oct 12 15:31:48 2010 Minimal instrumentation of module "c:\\p4ws\\depot\\qa\\fi\\fi_main.br\\project\\qaframework\\bin\\release8\\qafoundationsbase_210800_01.qag" was successful.
Tue Oct 12 15:31:50 2010 Minimal instrumentation of module "c:\\p4ws\\depot\\qa\\fi\\fi_main.br\\project\\qaframework\\bin\\release8\\stlport.5.0.dll" was successful.
Tue Oct 12 15:31:50 2010 Static instrumentation done
Tue Oct 12 15:32:01 2010 Preparing batch file:C:\\temp\\Cache\\DllLevelCache\\vtcopy.bat
Tue Oct 12 15:32:01 2010 Preparing batch file:C:\\temp\\Cache\\DllLevelCache\\vtrestore.bat
Tue Oct 12 15:32:01 2010 Copying files to destination directory"

I have tried this a few times going through various cleans and rebuilds of the modules being profiled, and having the application launched as an exe or via a script. Also, I have searched for processes holding locks on the source and targets of the copies in vtcopy.bat. If I do run vtcopy.bat by hand that appears to succeed. However I haven't figured out how to use this, as the checkbox "Copy and restore the files automatically" in the "Copy Instumented Modules Dialog Box" is greyed out (and checked).

Best,
Jon
0 Kudos
2 Replies
Peter_W_Intel
Employee
59 Views

Hi Jon,

My quick suggestions are:

1) Use latest product v9.1 Update 8
2) Remove all contents in Call Graph Cache
3) Rebuild your application, then redo

Thanks, Peter
Jonathan_Moore
Beginner
59 Views

Thanks. I've now been able to use vtcopy.bat by not having a launched executable associated with the activity (I'm sure this is documented somewhere that I missed). Still don't know why the copying reported an error but this is not an issue for me now.
Reply