Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5022 Discussions

Call tree and bottom-up stopped working, VS C++

Stephen_T_1
Beginner
803 Views

 

 

I'm compiling and running a VS C++ application and then running it stand-alone with Vtune XE 2013

It was working fine and I could see the top-down and bottom-up calls trees but now for some reason

these will not go further than one level - is there something broken, set-up, 

What have I gone and done ?

Steve

stephethomas@gmail.com

0 Kudos
10 Replies
Robert_L_Intel1
Employee
803 Views

Hi Stephen - Is it possible you have set the filter by accident?  The "call-stack-mode" at the bottom?

Could you post a screen-shot?

0 Kudos
Stephen_T_1
Beginner
803 Views

 

 

Please find the screen shot attached

I'm quite stuck, any help would be appreciated

Steve

0 Kudos
Kevin_O_Intel1
Employee
803 Views

 

Hi Steve,

Could you share your vtune amplifier xe result directory?(or if you prefer... you could send it to me directly)

Also... what compiler version are you using?

Kevin

0 Kudos
Stephen_T_1
Beginner
803 Views

 

I'm using the Visual Studio C++ compiler, 2010

Can I send the result directory to you (zip'ed )

0 Kudos
Stephen_T_1
Beginner
803 Views

 

zip'ed result directory attached

 

 

0 Kudos
Vitaly_S_Intel
Employee
803 Views

Hi Stephen!

I see your results are collected with "--mrte-mode=managed" - in VS it is inherited from VS settings (debugging -> managed). Since your application is native, you need to change this option.

If you are unable to find this setting in VS, you can try standalone VTune (not the one integrated to VS) - create new project and run Basic Hotspots there, you should see call stacks now.

0 Kudos
Stephen_T_1
Beginner
803 Views

Hi Vitaly

I have been running in Stand-Alone Vtune without launching from Visual Studio. Would this make a difference ?

What would you recommend. Should I somehow start over and create a new project in VTune ?

I can not find the option you mentioned in VS, would it be under compiler C++ or linker ?

Thanks

Stephen

0 Kudos
Stephen_T_1
Beginner
803 Views

 

Found the tools, debugging options, I'm using VS2010 so the compatabilty mode is not an

available option

There has to be some other reason why the call stacks are not showing up ?

 

0 Kudos
Vitaly_S_Intel
Employee
803 Views

Stephen, please check the following options in VS (depending on VS version):

- Configuration Properties -> Debugging -> Debugger Type (should be Auto or Native)

- Debug -> Enable unmanaged code debugging (should be turned on)

If you collect data using VTune standalone, please make sure the following option has correct value:

- Project Properties -> Managed code profiling mode = Auto or Native

0 Kudos
Stephen_T_1
Beginner
803 Views

 

Thank-you !!!

It was set to Managed in Vtune and switching to Auto corrected the problem

Much appreciated !

0 Kudos
Reply