Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Joris_P_
Beginner
139 Views

Communication with sampling driver failed

I am trying to do General Exploration analysis, and the following error appears almost immediately after trying to attach to the process,

"Communication with sampling driver failed".

I'm running on Windows 7, on a Intel Xeon CPU E5-2680 (2 processors). Doing the Basic Hotspot Analysis went fine. Any ideas - or things I could try?

 

Cheers,

-J

 

 

0 Kudos
11 Replies
Vitaly_S_Intel
Employee
139 Views

Hi Joris,

You can try to reload sampling driver using the following commands:

<VTune install dir>/bin64/amplxe-sepreg -u

<VTune install dir>/bin64/amplxe-sepreg -u pax

<VTune install dir>/bin64/amplxe-sepreg -i

Didn't you upgrade to new VTune version recently? Or that happens for you right after first install?

Joris_P_
Beginner
139 Views

Hi Vitaly,

 

Thanks for the reponse. I tried it (see below), but unfortunately that did not solve the issue. Note that this is the first time I attempt this analysis - I only had the installation done yesterday.

 

C:\Program Files (x86)\Intel\VTune Amplifier XE 2015\bin64>amplxe-sepreg -u
Stopping and removing sepdrv3_15...OK
Stopping and removing VTSS++ driver...OK

C:\Program Files (x86)\Intel\VTune Amplifier XE 2015\bin64>amplxe-sepreg -u pax
Stopping and removing sepdrv3_15...NOT FOUND
Stopping and removing sepdal...OK
Stopping and removing VTSS++ driver...NOT FOUND

C:\Program Files (x86)\Intel\VTune Amplifier XE 2015\bin64>amplxe-sepreg -i
Installing and starting sepdrv3_15...OK
Installing and starting sepdal...OK
Installing and starting VTSS++ driver...OK

C:\Program Files (x86)\Intel\VTune Amplifier XE 2015\bin64>

Vitaly_S_Intel
Employee
139 Views

Does it happen for Advanced Hotspots with stacks collection enabled?

Joris_P_
Beginner
139 Views

Yes, that fails in the similar way.

(To be sure: I intepreted this as running the Advanced Hotspot analysis, and and selecting the "Hotspots, stacks and context switches" radio button)

David_A_Intel1
Employee
139 Views

And, just to confirm, if you select "Hotspots" only (no stacks and context switches), does it succeed?

Joris_P_
Beginner
139 Views

Yep - just "Hotspots" works fine.

David_A_Intel1
Employee
139 Views

Thanks.

And what version of VTune Amplifier are you using (i.e., what is the output of 'amplxe-cl -version')?  Have you upgraded to version 2015 Update 3 (released this week)?

Joris_P_
Beginner
139 Views

Currently:

Intel(R) VTune(TM) Amplifier XE 2015 Update 2 (build 393444) Command Line Tool
Copyright (C) 2009-2014 Intel Corporation. All rights reserved.

I'll give the upgrade a go after the weekend and report back. I haven't done any changes/upgrades myself since our IT department installed it on my machine yesterday. Thanks for the help!

-J

 

Joris_P_
Beginner
139 Views

I upgraded to "Update 3" - but that hasn't helped. The manifestation of the problem slightly changed, though, as now I no longer get the error message "Communication with sampling driver failed", but instead it instantly cuts out and just says "Collection failed. The data cannot be displayed". The basic hot spot analysis still works fine. (I also followed the steps again to restart the driver as listed earlier).

Ahsan_Javed_A_
Beginner
139 Views

Hi,

I am using Intel vtune 2015, Update 3 and I also get the same error when I run advanced hots with call stacks enabled or general-exploration with

call stack enabled. I use the following command

/opt/intel/vtune_amplifier_xe_2015.3.0.403110/bin64/amplxe-cl -collect advanced-hotspots -knob sampling-interval=1000 -knob collection-detail=stack-and-callcount -knob event-mode=all -knob enable-user-tasks=false -knob enable-gpu-usage=false -knob enable-gpu-runtimes=false -follow-child -mrte-mode=auto -target-duration-type=short -no-analyze-system -data-limit=1024 -slow-frames-threshold=40 -fast-frames-threshold=100 -no-analyze-kvm-guest $java_home/bin/java test

which results in following output

amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /home/ajawan/recore_internship/test_java/r013ah -command stop.
amplxe: Warning: To enable hardware event-base sampling, VTune Amplifier has disabled the NMI watchdog timer. The watchdog timer will be re-enabled after collection completes.
amplxe: Collection failed.
amplxe: Internal Error


I have also tried, reloading the drivers and permissions are for all drivers are also set 666.

Any idea, how can I resolve the issue.

Regards

Ahsan

 

139 Views

Hi Ahsan,

The orig problem with quite old 2015 U3 release was reported on Windows, and you seems using Linux host.

Is it possible for you to upgrade on the 2016 U4 release and reproduce the behavior?

Regards, Katya

Reply