Community
cancel
Showing results for 
Search instead for 
Did you mean: 
53 Views

Drill-down error for Linux kernel module

When attempting: "vtl view -hf -mn wanpipe" VTune returns with "An error occurred during drill-down. Cause of error cannot be determined". Using "-hf" for the kernel works fine (it also works fine for executables and libraries). A possible issue is that the module in question is built outside the kernel tree (standalone make environment that uses the kernel tree, but is not built as part of it). As a result VTune may not be able to find the module binary or use the System.map file appropriately? I tried using the "-sd" and "-symbol-directory" options to "vtl view" as per other posts and the VTune documentation. But, "vtl view"rejects these options as "unknown and ignored". I also tried a soft link for the module name to the actual module with its ".ko" extension per another post to this forum... that did not help either.The module does contain the expected symbols as verified via "nm". Any ideas?
0 Kudos
1 Reply
Peter_W_Intel
Employee
53 Views

When attempting: "vtl view -hf -mn wanpipe" VTune returns with "An error occurred during drill-down. Cause of error cannot be determined". Using "-hf" for the kernel works fine (it also works fine for executables and libraries). A possible issue is that the module in question is built outside the kernel tree (standalone make environment that uses the kernel tree, but is not built as part of it). As a result VTune may not be able to find the module binary or use the System.map file appropriately? I tried using the "-sd" and "-symbol-directory" options to "vtl view" as per other posts and the VTune documentation. But, "vtl view"rejects these options as "unknown and ignored". I also tried a soft link for the module name to the actual module with its ".ko" extension per another post to this forum... that did not help either.The module does contain the expected symbols as verified via "nm". Any ideas?

Hi,

If you want to drill down to hot functions in module "wanpipe", please ensure that you have compiler switch "-g" used for executable building. Otherwise, please use "vtl view -ha -mn wanpipe" instead.

To look for right module which is an executable used during sampling data collection, please use:vtl global-options binary_search_dirs|symbol_search_dirs="your_path"

Above settings are good for all projects/activities, until you change them again.

Regards, Peter