Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
16 Views

font size problem in source code view

Machine Details:
vtune_linux_9.1
Intel Fortran 10.1.017
SGI Altix Itanium running SLES9 SP 3

I have succesfully run the "first use" analysis on a program compiled with -g using vtlec. However when I look at the list of symbols in a particular module and then choose a specific routine, the resulting source view is unreadable (text drawn as lines a few pixels long) and there is a stream of console errors:

** (Intel SDP:9412): CRITICAL **: file pango-context.c: line 220 (pango_context_load_font): assertion `pango_font_description_get_size (desc) != 0' failed

text in other panels is OK

I'd add some screen shots if I could work out how to...
0 Kudos
3 Replies
Highlighted
Employee
16 Views

Intel VTune Analyzer 9.1 and Intel Fortran Compiler have different Eclipse* version, did you install VTune with Intel? Fortran's Eclipse?

Try uninstall/reintsall VTune Analyzer with Eclipse* and BEA? JRocket JVM in vtune package.

Regards, Peter
0 Kudos
Highlighted
Beginner
16 Views

Intel VTune Analyzer 9.1 and Intel Fortran Compiler have different Eclipse* version, did you install VTune with Intel? Fortran's Eclipse?

Try uninstall/reintsall VTune Analyzer with Eclipse* and BEA? JRocket JVM in vtune package.

Regards, Peter
Sorry, no joy.

I didn't think that eclipse had been installed with the original fortran - it would appear that eclipse has only become part of the fortran install since version 11.

I have now installed VTUNE on a clean em64t/ia32e/intel64 (which term are intel going to settle on!) which has never had vtune, fortran or idb installed on it before. I still get the very small greeked text.

The Call Graph display has a similar problem. Initially it is drawn very small. Fortunately the zoom allows you to increase the size to make it readable. You do need to press the zoom button about 70 times though!


0 Kudos
Highlighted
Employee
16 Views

Quoting - Laurence Page
Sorry, no joy.

I didn't think that eclipse had been installed with the original fortran - it would appear that eclipse has only become part of the fortran install since version 11.

I have now installed VTUNE on a clean em64t/ia32e/intel64 (which term are intel going to settle on!) which has never had vtune, fortran or idb installed on it before. I still get the very small greeked text.

The Call Graph display has a similar problem. Initially it is drawn very small. Fortunately the zoom allows you to increase the size to make it readable. You do need to press the zoom button about 70 times though!


Sorry for late response because of my holiday.

I don't your display resolution, but you increased the size to make it readable - actually you try to change font size in source view panel, by doing Eclipse*->Preferences->VTune Performance Analyzer->Source View-> "Source View Font" to click "Change..." button.

Hope it helps.

Regards, Peter
0 Kudos