Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Li_Z_Intel1
Employee
68 Views

Error: Too many events are opened

my command line:

amplxe-cl -collect memory-access -knob sampling-interval=100 -target-pid=50457

Output message

amplxe: Warning: To profile kernel modules during the session, make sure they are available in the /lib/modules/kernel_version/ location.
Duplicate Event Discarded: MEM_LOAD_UOPS_L3_MISS_RETIRED.LOCAL_DRAM_PS
Duplicate Event Discarded: MEM_LOAD_UOPS_L3_MISS_RETIRED.REMOTE_DRAM_PS
amplxe: Warning: Event-based sampling analysis with sampling drivers supports collection of precise events. For driverless collection, these events will be collected as non-precise: MEM_UOPS_RETIRED.ALL_LOADS_PS,MEM_UOPS_RETIRED.ALL_STORES_PS,MEM_TRANS_RETIRED.LOAD_LATENCY_GT_4,MEM_LOAD_UOPS_L3_MISS_RETIRED.LOCAL_DRAM_PS,MEM_LOAD_UOPS_L3_MISS_RETIRED.REMOTE_DRAM_PS,MEM_LOAD_UOPS_RETIRED.L3_HIT_PS,MEM_LOAD_UOPS_RETIRED.L3_MISS_PS,MEM_LOAD_UOPS_L3_MISS_RETIRED.REMOTE_HITM_PS,MEM_LOAD_UOPS_L3_MISS_RETIRED.REMOTE_FWD_PS
amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /home/arda/log/r016macc -command stop.
amplxe: Per-node peak bandwidth measurement is enabled for this collection. Collection time may increase.
^Camplxe: Error: Error:
Too many events are opened.
Try again after reducing the number of events.

amplxe: Collection failed.
amplxe: Internal Error

Sorry, I don't know how to reduce events number, can you help me?

0 Kudos
1 Reply
James_S
Employee
68 Views

Hi Li,

Can you please try to have a look at the limits you have set: # ulimit -a

And then set the ‘open files’ limit higher than the amount of cpu threads: # ulimit -n 10240

Best regards,

Zhuowei

Reply