Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Petros
Beginner
80 Views

General Exploration: Resolving information for 'libc-2.13.so'

Hi,
When trying to run any of the Advanced Intel Core 2 Processor Family Analysis, they run ok and when analysing the data they get stuck on "Resolving information for 'libc-2.13.so'". I usevtune_amplifier_xe_2011(build 128765).
system info
libc problem
I added the library at LD_PRELOAD but again it gets stuck there.
Also, when running a concurrency analysis I get:
Warning: Symbol file is not found. The call stack passing through the module /opt/intel/composerxe-2011.2.137/compiler/lib/intel64/libiomp5.so may be incorrect Warning: Symbol file is not found. The call stack passing through the module /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_core.so may be incorrect Warning: Symbol file is not found. The call stack passing through the module /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_sequential.so may be incorrect Warning: Symbol file is not found. The call stack passing through the module /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_intel_lp64.so may be incorrect Warning: Symbol file is not found. The call stack passing through the module /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_mc.so may be incorrect
Afterwards I can see the analysis but not inside libomp5 etc to see exactly where the time is spent. I also added these libraries to the LD_PRELOAD but again nothing.
The inspector loads the modules OK:
Loaded module: /lib64/ld-linux-x86-64.so.2. Loaded module: /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_intel_lp64.so. Loaded module: /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_sequential.so. Loaded module: /opt/intel/composerxe-2011.2.137/mkl/lib/intel64/libmkl_core.so. Loaded module: /lib/x86_64-linux-gnu/libpthread.so.0. Loaded module: /opt/intel/composerxe-2011.2.137/compiler/lib/intel64/libiomp5.so. Loaded module: /lib/x86_64-linux-gnu/libm.so.6. Loaded module: /lib/x86_64-linux-gnu/libc.so.6. Loaded module: /lib/x86_64-linux-gnu/libgcc_s.so.1. Loaded module: /lib/x86_64-linux-gnu/libdl.so.2. Loaded module: /opt/intel/inspector_xe_2011/bin64/../lib64/runtime/libittnotify.so.
Any advice?
Thanks,
Petros
0 Kudos
2 Replies
Mark_D_Intel
Employee
80 Views

Try upgrading to Update 2. A very similar problem (hang when resolving symbols in different version of libc) was fixed there.
Petros
Beginner
80 Views

Try upgrading to Update 2. A very similar problem (hang when resolving symbols in different version of libc) was fixed there.

I will try tomorrow first thing! Thanks!
UPDATE:
Updating vtune to update2 2011 solved the libc problem. But not theSymbol file is not found ones!
Reply