Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
3 Views

General Exploration stopping before the application ends

Hi,

I am writing here to report an issue I have when using VTune to do some specific analysis.

This issue is that, when collecting data, VTune will launch my application, and stop it after about 1-2 seconds (not always at the same exact time, this is not quite deterministic) and present the results it has collected during that time, which don't represent the whole process as my application in this "test case" takes 7 seconds to run.

This problem does not occur on every analysis : I can do a Hotspots or a Memory Access analysis just fine, without VTune interrupting my application.

To make sure that this was not the problem, I changed the Collection Data Limit in the project properties to be 100 times the default value, but it did not have any impact on this issue.

I am performing these analysis on a Sandy Bridge processor, using the Sandy Bridge specific Analysis (except for Hotspots where i use the general one), and am running on Windows 7 from Visual Studio 2010.

I would be very grateful if you can give me any explanations on that, so far I have found a lot of very interesting features in VTune that could help me a lot, but those issues as well as the 2 BSODs that I have encountered thus far are setting me back a little.

Thank you

0 Kudos
3 Replies
Highlighted
Employee
3 Views

I understand that you didn't have problem to run user-mode sampling data collection (e.g hotspots analysis), just had problem to run PMU event-based sampling analysis, on Sandy Bridge?

I wonder if you don't use "Automatically stop collection after " - it will not interrupt (terminate) your running application.

Is ityour program specific issue? Or it is applicable for other application?

What is your VTune Amplifier XE version (build number)? CPU info (family, mode, stepping)?

Thanks for your interest of trying VTune Amplifier XE 2011.

Regards, Peter
0 Kudos
Highlighted
Beginner
3 Views



Exactly, I only get this problem (of analysis ending early) when I run PMU event-based sampling analysis on Sandy Bridge.


I confirm that I don't use "Automatically stop collection after".

I also tried with the Tachyon sample, and this problem does not happen, so it appears to be specific to my program (a video encoder).

My version of VTune is :VTune Amplifier XE 2011 update 4, build number :176374

CPU Info : Intel Core i7 2600 (Sandy Bridge)
Family : 6
Model : A
Stepping : 7

Thanks for your help

Arthur
0 Kudos
Highlighted
Employee
3 Views

Another way is to try attach-to-process feature, assume that your application will run longer.

1. Manually launch application, and get pid of process
2. amplxe-cl -collect snb_general-exploration -duration N -target-pid pid

You also can go https://premier.intel.comto submit this issue with test case, for investigating why application stopped if launched by amplxe-cl

Regards, Peter
0 Kudos