Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
9 Views

How to know which part of a procedure is time-consuming ?

Jump to solution
Hi,

I trying for the first time to use the Intel VTune Amplifier on a fortran code using the last Intel Composer XE for linux (Update 7).
I am working on linux, using the Fedora 15 distribution.

I created a new projet and set my fortran binary file as the application target in the "Project Properties" window.
Then, I've chose the "Hotspts" in the "Analyse type" window and pressed the start button.
The analysis start and VTune collects hostspot data during the code execution.
After about 60s, the analysis end.
Up to here, everything go well.

My problem is in the Bottom-up menu.
When a double-click on a procedure name in order to see which part of the procedure is time-consuming, I have no information for the "Line" and "Assembly" field. Actuelly, the "Assembly" colum has unreadable information.

So, my questions are:

How can I know which part of the source code of a procedure is the most time-consuming?
Should I use specific compilation options ?


(I am using -pg option)

Thanks for your help.
F.H.



0 Kudos

Accepted Solutions
Highlighted
Employee
9 Views
Did you use "-g" to build program?
Is it possible that you used "-O2" or "-O3" sosome inline functions can't be displayed as "hot function"?

Please check with other simple application, built by ifort. If this is your program specific issue, please go to https://premier.intel.com to submit a ticket with test case (source or/and binary).

Thanks, Peter

View solution in original post

0 Kudos
3 Replies
Highlighted
Employee
10 Views
Did you use "-g" to build program?
Is it possible that you used "-O2" or "-O3" sosome inline functions can't be displayed as "hot function"?

Please check with other simple application, built by ifort. If this is your program specific issue, please go to https://premier.intel.com to submit a ticket with test case (source or/and binary).

Thanks, Peter

View solution in original post

0 Kudos
Highlighted
New Contributor I
9 Views
Thanks. Problem solved !!!

I was not using the "-g" compiler option. In addition, I was using the "-O2" option which was preventing some functions to be displayed.
0 Kudos
Highlighted
Black Belt
9 Views
Rather than removing -O2, you might try various ways of removing interprocedural optimizations, so as to preserve many of the optimizations. -fno-inline-functions together with removing IPO used to be fairly effective.
0 Kudos