Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5036 Discussions

Incorrect VTune configuration on Lenovo ThankPad

Van_Veen__Lennaert
1,010 Views

I run Ubuntu 20.04 on a Lenovo ThinkPad and just installed OneAPI with C and Fortran compilers, MKL and VTune. When I ran VTune on an MPI code, I got the message:

"This analysis requires one of these actions: a) Install Intel Sampling Drivers. b) Configure driverless collection with Perf system-wide profiling. To enable Perf system-wide profiling, set /proc/sys/kernel/perf_event_paranoid to 1 or set up Perf tool capabilities."

I tried option a) by following the instructions here:

https://www.intel.com/content/www/us/en/develop/documentation/vtune-help/top/set-up-analysis-target/linux-targets/build-install-sampling-drivers-for-linux-targets.html

and those in /opt/intel//oneapi/vtune/latest/sepdk/src/README

and all scripts finished without error messages. However, when I run

> insmod-sep -q
pax driver is loaded and owned by group "users" with file permissions "660".
socperf3 driver is not correctly loaded.
sep5 driver is not correctly loaded.

socwatch driver is loaded and owned by group "users" with file permissions "660".

vtsspp driver is loaded and owned by group "users" with file permissions "660".

 

It appears that "socperf3" and "sep5" are broken somehow, or it could be a problem with the "groups" and permissions. Any help would be appreciated!

0 Kudos
4 Replies
Van_Veen__Lennaert
1,003 Views

Update: I used "usermod" to add myself to groups "vtune" and "users", then re-booted. Perhaps some other changes had been pending. Now, I see:

>./insmod-sep -q
pax driver is loaded and owned by group "users" with file permissions "660".
socperf3 driver is loaded and owned by group "users" with file permissions "660".
sep5 driver is loaded and owned by group "users" with file permissions "660".

socwatch driver is loaded and owned by group "users" with file permissions "660".

vtsspp driver is loaded and owned by group "users" with file permissions "660".

 

Ansd VTune seems to work! Not quite sure what did the trick TBH.

0 Kudos
RaeesaM_Intel
Moderator
982 Views

Hi,


Thank you for posting in Intel Forums.

Glad to know that your issue is resolved. Is there anything else that we can help you with ?


Regards,

Raeesa


0 Kudos
Van_Veen__Lennaert
972 Views

Not for now, thanks!

0 Kudos
RaeesaM_Intel
Moderator
965 Views

Hi,


Thank you for the confirmation. We are discontinuing monitoring this thread. Please raise a new query in case of any further issues. We will be happy to help.


Regards,

Raeesa


0 Kudos
Reply