Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Minnie_H_Intel
Employee
97 Views

Installation of VTune on Linux 2.6.33.7 with pre-empt extensions

Installation of VTune on Linux 2.6.33.7 with pre-empt extensions

--------------------------------------------------------------------------------

In installing Vtune on Linux (Kernel version 2.6.33.7, Debian release "squeeze", with Pre-empt real-time extensions), I get a message that the sampling driver failed to build and needs to be compiled manually.

When I manually build the sampling driver (using the kernel source code), I get the following error message:

In function 'samp_configure_ex', line 4703: error: expected expression before '{' token.

The kernel works, and it was built from the source code that I am using for Vtune driver installation.

Has anyone else encountered this error message and know what I can do fix this?

Minnie

0 Kudos
1 Reply
Peter_W_Intel
Employee
97 Views

Hi Minnie,

As I know latest product v9.1 Update 8 has been tested under Linux* kernel 3.6.31, please see release notes to know supported operation systems.

If running latest product in the sytsem which Linux* kernel is higher than 2.6.32 - it takes high risk.

Thanks, Peter
Reply