Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
26 Views

Intel vtune is very slow in finalizing results(linux)

Hi,

I'm using intel vtune amplifier 2015(linux version). my sample time of the work load is 180 seconds. I gave my SW build with debug symbols enabled. 

In vutune->project properties, I gave the path for the build and the source files and symbols. When i give re-resolve, vtune takes more than 1 hour to finalize and display results. The progress bar goes to 30% and remains stuck there and it says "finalizing results " for more than an hour.

What is the problem here. why does it take so long to display results when i hit re-resolve?

looking forward to your reply.

Thanks and regards,

vaibhav

0 Kudos
5 Replies
Highlighted
Employee
26 Views

Hi vaibhav:

Are any of the files or results on an NFS drive?  The performance of NFS drives will impact performance of VTune Amplifier if any files it needs reside on the NFS drive.

There are many variables that will make it difficult to give you a definitive answer over the forums.  The best thing I can recommend is to build and profile one of the samples included in the product, e.g., tachyon, matrix, etc.  There are known quantities and if you see similar issues, then the problem lies with your system and/or application.  For example, how large is your binary?  If you build without symbols, is finalization any faster?  What debug symbol format is the compiler generating?  What compiler are you using? etc. etc.??

But, as I said, make sure you aren't using NFS drives and try one of the samples.  Then, let us know your results.

0 Kudos
Highlighted
Employee
26 Views

Hi vaibhav,

Can you please tell which VTune release or build number do you use? You'll find it in About dialog.

Can you also provide VTune output or at least the message which takes most of the time? Use "amplxe-cl -I -r <path to result>" to reproduce it in command line.

0 Kudos
Highlighted
Beginner
26 Views

 

Hi,

Thanks very much for your response. All the files stored locally on the system.I'm using vtune 2015 Update 3 (build 407750). I'll send you the log files soon.

This problem occurs when i give some build paths in the source and symbol paths in project properties.

cheers,

vaibhav

0 Kudos
Highlighted
Employee
26 Views

Hi vaibhav,

Can you please upgrade to 2015 Update 4 and check again? There were significant performance improvements on finalization for occasional cases.

In case it doesn't help, can I ask you to run the following command when you get the message taking most of the time?

amplxe-feedback.exe -no-system-info -create-bug-report slow

It'll dump running VTune processes which will allow us to analyze executing context. Result of this command - slow.zip file in current directory, please send it to me using private message (it'll also include VTune logs from recent sessions). You'll find amplxe-feedback in <VTune install dir>/bin64.

Thanks!

0 Kudos
Highlighted
Beginner
26 Views

Hi,

I have used vtune command line version with deferred Mode on MPI program, It's been taking a very very long time to finalize the results. It has been stuck with

"amplxe: Executing actions 90 % Loading '17919-17926.0.trace' file"

message for 30Hrs. And i couldn't see any change in the size of folders in result directory...!!! And its Intel Parallel Studio 2017 version. Why is this happening, any solution for this? And if we stop the process at 90% action, could we be able to re-finalize the result with -finalize action using the same result directory and same executable? Does it change any values in the re-finalized report?

Thank you

0 Kudos