Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yunchen_li
Beginner
130 Views

Internal error occurs in Vtune 8.0

Hi,

I try to use callgraph to run my program on my linux machine, and it ends with internal error:

[root@Sample]# DISPLAY=:0 /opt/intel/vtune/bin/vtl activity -c callgraph -app ./xuiplayer -moi ./xuiplayer run
VTune Performance Analyzer 8.0 for Linux*
Copyright (C) 2000-2005 Intel Corporation. All rights reserved.

The Activity is running.
Wed Nov 29 14:43:35 2006 Reading property files started...

Wed Nov 29 14:43:35 2006 Reading property files done.

Wed Nov 29 14:43:36 2006 Static instrumentation started

......(blah blah)

Wed Nov 29 14:22:47 2006 Static instrumentation done
Wed Nov 29 14:22:47 2006 Data collection started...
Wed Nov 29 14:22:50 2006 Data collection finished...
Wed Nov 29 14:22:51 2006 Error - Internal error while resolving the results file.
Some errors occurred during the collection. The Activity was cancelled.

I try to use callgraph to run /bin/ls on my linux machine, it works:

[root@Sample]# /opt/intel/vtune/bin/vtl activity -c callgraph -app /bin/ls -moi /bin/ls run
VTune Performance Analyzer 8.0 for Linux*
Copyright (C) 2000-2005 Intel Corporation. All rights reserved.

Wed Nov 29 14:32:34 2006 Warning for module "/bin/ls" - The module is stripped (Instrumentation degraded to MINIMAL).
The Activity is running.
Wed Nov 29 14:32:35 2006 Reading property files started...

......(blah blah)

Wed Nov 29 14:32:39 2006 Data collection finished...
Wed Nov 29 14:32:39 2006 Updating Call graph database...
Wed Nov 29 14:32:39 2006 Trying to find symbols for module (1 / 6) /lib/tls/libc.so.6
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Trying to find symbols for module (2 / 6) /lib/tls/librt.so.1
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Trying to find symbols for module (3 / 6) /bin/ls
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Trying to find symbols for module (4 / 6) /lib/libattr.so.1
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Trying to find symbols for module (5 / 6) /lib/libacl.so.1
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Trying to find symbols for module (6 / 6) /lib/libselinux.so.1
Wed Nov 29 14:32:40 2006 Succeeded!
Wed Nov 29 14:32:40 2006 Done.
The Activity has finished running.

I logged in as root user, I try to remove the vtune related folders that were mentioned in earlier discusses.
(
rm -rf /root/VTune
rm -rf /opt/intel/vtune/global_data/ISM/
rm -rf /tmp/vtune_root
)
I still get the same message of internal error when I try to use callgraph to run my program on my linux machine

Could anyone give me suggestion?
I'm appreciated any reply.
0 Kudos
3 Replies
TimP
Black Belt
130 Views

The first question would be why you would struggle with an old version of VTune. Internal errors in current versions are, without question, best dealt with by submitting a bug report. With older versions, of course, you would run into situations where you could recover after a successful data collection by exiting from VTune, perhaps logging out of the OS, then resuming your VTune session.
yunchen_li
Beginner
130 Views

Hi tim18, thnak you for your reply.
You meant that I should try to use new version of Vtune?

I re-intalled Vtune to Vtune 8.0.2 build 608 and tried to use Vtune to run my program again.
It still ended with internal error.

[root@Sample]# DISPLAY=:0 /opt/intel/vtune/bin/vtl activity -c callgraph -app ./xuiplayer -moi ./xuiplayer run
VTune Performance Analyzer 8.0.2 for Linux*
Copyright (C) 2000-2006 Intel Corporation. All rights reserved.

The Activity has been successfully created.
The Activity is running.

.....

/home/Sample/xuiplayer: /tmp/vtune_root/Cache/libgcc_s.so.1: version `GCC_3.3' not found (required by /tmp/vtune_root/Cache/libstdc++.so.6)
/home/Sample/xuiplayer: /tmp/vtune_root/Cache/libgcc_s.so.1: version `GCC_3.3' not found (required by /tmp/vtune_root/Cache/libstdc++.so.5)
Tue Dec 5 11:33:19 2006 Exports instrumentation of module "libz.so.1.2.1.2" was successful.
Tue Dec 5 11:33:19 2006 Static instrumentation done
Tue Dec 5 11:33:29 2006 Data collection finished...
Tue Dec 5 11:33:30 2006 No module from the activity was loaded
Tue Dec 5 11:33:30 2006 Error - Internal error while resolving the results file.
Tue Dec 5 11:33:30 2006 WARNING: no module of interest was loaded during activity
Some errors occurred during the collection. The Activity was cancelled.


I tried to use sampling to run my program, and it worked.

[root@Sample]# DISPLAY=:0 /opt/intel/vtune/bin/vtl activity -c sampling -app ./xuiplayer run
VTune Performance Analyzer 8.0.2 for Linux*
Copyright (C) 2000-2006 Intel Corporation. All rights reserved.

The Activity has been successfully created.
The Activity is running.
Tue Dec 5 12:18:14 2006 Sample (Run 0) Setting Sampling CPU mask to 0-1
Tue Dec 5 12:18:14 2006 Sample (Run 0) The processor PMU configuration file: pmy.xml
Tue Dec 5 12:18:14 2006 Sample (Run 0) Collection for the following event(s) is being performed:
Tue Dec 5 12:18:14 2006 Sample (Run 0) Clockticks, Instructions Retired.

...........

Tue Dec 5 12:18:32 2006 Sample (Run 0) Sampling data was successfully collected.
The Activity has finished running.



TimP
Black Belt
130 Views

Now it looks as if you don't have the gcc libraries expected by VTune. If your gcc and glibc installations are within the range given as prerequisites for VTune, you should file a problem report on premier.intel.com. If your gcc is much older than 3.3, you may need to upgrade it, or make do with gprof for call graphing.
Reply