Community
cancel
Showing results for 
Search instead for 
Did you mean: 
optimism
Beginner
69 Views

Issue with the display of the required DLL functions

Hello all,

I am new to this VTUNE performance tool. The only issue I am facing with the tool is that I am not able to get the display of the functions of a particular DLL (to be more specific ,a server DLL)which I am mentioning under the modules of interest, nevertheless , I am successful in doing so for the DLLs which are getting invoked by default ,by the application (I mean the exe file). Hope one of you could help me out in this regard.

Thanks,

Raghu

0 Kudos
2 Replies
TimP
Black Belt
69 Views

In principle, it should be possible to see the exported symbols of the .dll, if sufficient samples have been taken while those functions are active. Building it with /Zi gives the maximum opportunity. I've found it difficult to get useful VTune profiling information in functions which don't account for more than 1% of execution time. If you need to do that, you might consider the VTune API to turn on sampling only for the functions of interest.
optimism
Beginner
69 Views

Quoting - tim18
In principle, it should be possible to see the exported symbols of the .dll, if sufficient samples have been taken while those functions are active. Building it with /Zi gives the maximum opportunity. I've found it difficult to get useful VTune profiling information in functions which don't account for more than 1% of execution time. If you need to do that, you might consider the VTune API to turn on sampling only for the functions of interest.


Hello,

I am trying to get the Performance evaluated for one of my server Dlls. I had built the Dll using /Fixed:no . I have attached the screen shot of the Dll involved(ergoplandoimpl.dll). You can see the Instrumentation Status is OK but still I am unable to see the functions of this Dll in the Module Window . What could be the reason ?

Thx

Sameer

Reply