Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Sandip_G_1
Beginner
82 Views

No Data from vtune on Linux with g++

Hi, I am running VTune Amplifier XE 2015 Update 4 (build 410668) for basic hotspot analysis of my C++ application which uses several external libraries. I have compiled the program with -g option. Unfortunately VTune throws an error like so: ?invalid? has faced a serious problem Mo 24 Aug 2015 19:00:05 CEST Cannot open data: ?invalid? has faced a serious problem. Error 0x40000024 (No data) -- No data is collected. Possible reasons: - Workload is too small. No samples are collected. - The application environment is not specified correctly. See the Troubleshooting help topic for more details. So I went back to testing the tachyon example and I get the same error. Any hints on what might be the problem is much appreciated. Does VTune work only with icc/Intel C++ compilers? Best regards, Sandip
0 Kudos
5 Replies
David_A_Intel1
Employee
82 Views

Hi Sandip:

VTune Amplifier will work with binaries produced by any C++ compiler that follows industry standards.  For example, it works just fine with g++.  Which compiler and linker are you using?

Is this on Windows* or Linux*?  Which release?

Can you launch the application outside of VTune Amplifier without any issues?  Can you start VTune Amplifier from the same environment that you are able to launch the application from?

WRT third-party libraries, are any of them tamper-resistant software that is intended to protect your code from viruses or infiltration by hackers? The software collectors use dynamic instrumentation to insert code into your binary after it is loaded into memory.  This can be construed as "tampering" by such libraries or software.

Have you tried the Advanced Hotspots, which does not use instrumentation?

David_A_Intel1
Employee
82 Views

Sorry.  I overlooked that you specified the compiler in the title.  VTune Amplifier works fine with g++.

Did tachyon work for you previously and now it doesn't?

Sandip_G_
Beginner
82 Views

Hi Mr. Anderson,

Thanks for your reply. I am using Ubuntu 14.10 and tachyon did not work even the first time due to some missing dependencies (libX11.so etc..). I am not able to run the application standalone (without VTune) so I guess that is my problem?

I will try the Advanced Hotspots option in the mean time.

 

Reporting back soon..

~S

Emile_S_
Beginner
82 Views

I'm trying out vtune on linux as well, and also got this error.

I started out running vtune on a virtualbox ubuntu 14.04 client (Mac host.) I grabbed the tachyon test client, and (after fixing the -I path for the X11 libraries) could compile it, and run the basic analysis. However, I wanted to try some of the hardware performance counter based profiling.

So I installed vtune on an older HP laptop (also running ubuntu 14.04) with an Intel Core Duo chip. I'm trying to run the vtune gui on my VM, with data collection on the laptop system. I set it up to use "Launch Application via SSH" collection. But, all the analyses other than basic fail to collect any data. Ultimately I would like to do remote profiling in a similar way (running GUI on local virtual machine instance, target system being a large headless machine in datacenter.)

Is there logging on the target system anywhere? Is the processor on my target system too old? How can I figure out why this isn't working? Thanks.

David_A_Intel1
Employee
82 Views

Hi Emile:

When you installed on the laptop, did you receive any errors during the sampling driver build and installation?

On the laptop, as root, cd to the installation directory (typically, /opt/intel/vtune_amplifier_xe) and then sepdk/src and execute the command './insmod-sep3 -q'.  Are three drivers loaded: pax, sep, and vtsspp?

It may be that the laptop is too old.  The Release Notes state "Core(TM)2 Duo processors."

If the drivers are loaded, try executing this command (after sourcing the amplxe-vars.sh file):

$ amplxe-cl -c advanced-hotspots -duration=5

Is there a message about not supporting the processor?

Reply