Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4823 Discussions

Problem installing Vtune Amplifier XE 2017 U17


Hi everybody,

I hope you can help with this. I downloaded the vtune_amplifier_xe_2013_update17 trial but I failed to install it on my Ubuntu 12.04 x86-64. The installed aborts with this message:

Initializing, please wait...
Something wrong with package. Please go to for your support options.

Have you got any hints about what could I do to complete the installation?

P.S: I included the /tmp/intel.pset.amoran.delta_08. in case it can help

0 Kudos
5 Replies

Ubuntu 12.04 should be supported, said in release notes.

Are you sure if your package is not corrupted, you may install it in other box which has a different operation system. Second step is to ensure, your Ubuntu 12.04 is not customized, so all utilities exists in the system, required by VTune installer . If operation system is customized, just copy whole VTune_DIR from other box (which installed the tool successfully) to this Ubuntu 12.04, then "export INTEL_LICENSE_FILE=/opt/intel/vtune", put your eval license to that folder. It is OK to run  "/opt/intel/vtune_amplifier_xe_2013/bin64/amplxe-cl" directly, also you may build/load vtune drivers  from /opt/intel/vtune_amplifier_xe_2013/sepdk/src/, if you want to use hardware PMU event-based sampling.



Hi Peter,

Thank you for your answer but no, the package does not look to be corrupted, I can uncompress it without any problem and the download looked all right. I tried a bit harder and I sorted it out this way:

  1. The installation GUI didn't work for me, don't know why
  2. There is a CLI_Install/ folder, I cd into it and run the ./ from theer

This time the installation went though. This is much better, but sadly it appears that it had not installed the GUI (i.e.: amplxe-gui is nowhere to be found) that is a pity (I was looking forward to evaluate if ti was worth buying it). 
I tried it "the manual way", that is I just uncompressed the rpms and copied them to /opt/intel. At this point I was able to launch the GUI and to setup an analysys, but then I couldn't go very far because there was an error complaining about a missing license. There is no *lic file in /opt/license, so I don't really know what to do now.

Have you got any helpful hin on how to tell what does the graphical installer expects me to do or have in order to complete the installation in a "normal" way? Is there any way to know what the installer want? How can I get the evaluation license?


Thanks for your descriptions in detail.

Usually I use, which will install all component, they are vtune collector, command utility, doc and GUI, everything. I suspect that your system might miss some GTK* libraries required by VTune, I experienced this from other customer who has customized operation system. That was why amplxe-gui not found, but you can run amplxe-gui after installing it "the manually way", probably the installer has done extra check for libraries missing, have you seen any warning message during installation.

Anyway, "the manually way" installation can work, I think it can. You can apply an eval license from this, and put license file under /opt/intel/license. 


When you registered for the "trail" version, or evaluation copy, you should have received an email, at the email address you registered with, including your serial number *and* a license file.  If you did not receive the license file, see these instructions for how to resend it to your registered email address.

The CLI_install folder is only for installing the collectors, e.g., on a remote system.  There are instructions for this in the Release Notes.

You need to use either or and, preferably, install as 'root'.  "sudo" is supported, but I recommend root, via 'su -' (the dash is important and causes the root login script to be executed so that privileged binaries are accessible).



Per install logs it seems that there was a problem of launching the following utility that checks licensing etc:


If possible could you please try to run it by hands from the location? Probably there are no executable permissions on the folder etc.

Thanks & Regards, Dmitry