Community
cancel
Showing results for 
Search instead for 
Did you mean: 
50 Views

Problems using OSX VTune

Just tried OSX VTune (to profile a remote Linux host) for the first time.  The overall experience started out really nicely.  Then it went completely off the rails.  Here's what happened and some suggestions to improve things:

1) setup of project went well

2) clicked "start and pause", and after a couple of seconds it showed a message saying that something went wrong and I needed to run the 'status' command -- without saying how

3) no sign of any status command in the GUI, searched docs and found out that amplxe-cl is needed

4) tried to run amplxe-cl on command line (no luck)

5) searched Mac and remote machine for amplxe-cl, with no luck

6) past experience with Mac dev tools led me to peek into the VTune OSX package manually, discovering the bash script to setup the command line tools -- pretty terrible user experience, especially since the application has all sorts of spaces in it and a .app extension that isn't obvious

7) tried status command with amplxe-cl, but it says it doesn't have such an option and sure enough its printed list of options doesn't include status like the docs imply it should -- why doesn't it have this option?

8) found dialog in GUI where the command being run is shown -- copy&pasted to terminal and ran it.  This produced a bunch of output from the Intel tool, include a note that no data was collected.  No clue as to why.

9) noticed that the remote command it was using was printed -- copy&pasted that to remote host ssh session and ran it.  This (finally) showed me my own program's output, and instantly _why_ it was failing almost as soon as it started.  Why wasn't my program's output captured and shown in the OSX GUI?!  Would have solved the problem in seconds instead of this wild goose chase through multiple command lines.

10) The results of the command line run don't appear in the GUI for some reason.  Re-run from the GUI now that the issue is resolved.  This time it worked and said please wait "a few moments" (which turned out to be about 10 minutes).

 

The VTune user experience, especially for remote profiling, has come very far.  Too bad it fell flat for me immediately upon trying to use it the first time from a Mac.

 

0 Kudos
1 Reply
Vitaly_S_Intel
Employee
50 Views

Hi Andrew,

There is an option in VTune GUI to configure application output destination - either use product output window or in the console. Can you please change it to "Product output window" and check if it helps to triage this problem?

Can you please also provide the screenshots for errors on 2 and 10? And amplxe-cl output for 4, 8?