Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DUBEDAT__Adrien
Beginner
86 Views

Remote Linux port and personal shared libraries not showing in results

Hello, I've started using Intel VTune yesterday to profile the program I've been working on.

I installed it on my Windows 10 host machine and have been connecting remotely to the Linux Docker where the program is running.

- The first issue I have is that I want to use port 2222 to connect to the Linux Docker, like I do when connecting manually via SSH to that same Linux Docker. For that, we use ''-p 127.0.0.1:2222:22 ^'' in the ''docker run'' command.

I specified ''root@127.0.0.1:2222'' as the SSH destination but the only way it works is that I had to specifiy ''-p 127.0.0.1:22:22 ^'' in the ''docker run'' command.

- The second issue I have is that once I ran one profiling session of a few seconds, I expect to see results that take into account the personal shared libraries I'm using and that contain code that I know is executed.

However, what I see is that over tens of seconds of elapsed time, the CPU time is only 0.010s or such low values.

I added the following the BuildSettings.cmake file:

set(CMAKE_BUILD_TYPE Debug)
set(CMAKE_XCODE_ATTRIBUTE_DEBUG_INFORMATION_FORMAT "dwarf")

and when compiling, the -g appears but VTune is still not seeing any of my personal libraries.

Thank you !

0 Kudos
1 Reply
DUBEDAT__Adrien
Beginner
86 Views

It seems that for some executions VTune is able to see some calls made in my shared libraries, but for same execution time during another run, it doesn't see any calls made in those .so files even though I'm sure the functions in those libraries are called.

Could it be that Docker has an impact when running VTune ?

How come those results differ from one application run to another run ?

Thanks !

Reply