Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

Source Code Pane

Where is the symbol file for an executable/binary file to be analyzed by Intel Vtune Amplifier? I have the complete system working, but I am unable to associate sourceor see the source code.

There are some old posts on this Forum about using somethinglike -s as a compile option. I do not understand that. Do I put in -s or take it out?

I can get source code associated with the binary file when I run the examples. It just does not work on my own programs.

As I said the whole VTUNE Amplifier System worksexcept for source code.

The error message :

Warning : Symbol file is not found. The call stack passing through the model **** may be incorrect.

Do I ignore this error? One Intel knowledge base post say to ignore it.

Stiil, I cannot associate the source and the executable/binary. I have redirected the search directories - still no luck,

Are the symbol files separate? If so where are they. What are their extensions?


0 Kudos
3 Replies
New Contributor II


It seems you have various running forum threads surrounding viewing source code.

The issue may becoming a bit obfuscated Perhaps some clarification and simplification is needed to move forward. Based on the threads, I believe you are able to drill to source code for the Tachyon sample after analysis correct? Perhaps you can provide additional information about the differences between your applications, compilation method, environment, type of application, etc. that might be different from the Tachyon example.

Another test, are you able to create your own simple sample application (like hello world) where you also cannot drill to the source from within an Amplifier analysis? This may provide some scope to the problem and perhaps uncover a cause.

Is there a way to determine what is different between the Tachyon example that works as expected and a simple application you have that does not allow you to drill into the applications source file. Are you attempting to drill into source that is not contained in the main source file but a library or other resource.

In regards to the warning: Symbol file is not found. The KB article VTune Amplifier XE collection warning: Symbol file is not found may provide some insight as to what is occurring.

- Rob


I can get the examples in the tutorial to run and show me the source code. I have a prime numner generating program that once did show the source code when I clicked on a function name. Now when I run it the bottom-up window and the top-down window show nothing and just say

No data to show
No data is available

I compile my programs with a script I do not use a makefile. The options that I use are

gcc -lm -lrt -g -O2 source.c.

That usually works; it does not work here.

I saw the memo on the Warning andI guess that explains the warning. When I run my program I see the file (program function names in the leftmost window), but upon clicking on the file name all I get is the assembly code. My primes program does not even show that; it just says:

No data to show
No data is available

It there a way to check source with command line options. I have other tools (not Intel) that make it easy to see source code, but they do not integrate in the VTUNE Amplifier IDE.

Everything works on my 4 core Xeon cpu, but viewing the source code.

Any help appreciated. Thanks in advance.



What is the -s option? Does it invoke the symbolic linker? I googled the error and someone wrote on this Forum to either put -s in or take it out in the makefile. Which is correct or are they both wrong?

Two things:
1. How long does your primes program run? What window shows the "No data to show" message? If it's the 'Bottom-up' or 'Top-down Tree' windows, then your application didn't generate any samples - the main cause of this is an application run that's too short (default sampling interval for hotspots is 10 milliseconds.)

2. The '-s' option is described in the 'ld' man page. It strips symbol information during the link phase - definitely not what you want.