Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)

Support for 2.6 kernel?

Intel_C_Intel
Employee
802 Views
Hello,

I was wondering when there will be a version of vtune that supports the 2.6 kernel instead of just the 2.4 kernel which is now the case as i understand from the release notes. I also see there is a commercial version of a vtune-alike program here from intel. Does this support 2.6 kernel?
If there is no solution yet, when is the release planned of a version with this feature.
0 Kudos
6 Replies
TimP
Honored Contributor III
802 Views
Support for 2.6 kernel is not yet released. If you have the paid-up version, and have a need for it, you might try submitting an issue on premier.intel.com asking to try out a pre-release version. Currently, it's a little lacking in polish as far as installation is concerned. Your license would be good for an upgrade within its term.
0 Kudos
jeffrey-gallagher
802 Views
Actually the current release of the VTune for linux product, VTune 3.0, supports several SuSE 2.6 kernels (see release notes for exact details).
Support for RH 2.6 is forthcoming.
0 Kudos
Intel_C_Intel
Employee
802 Views
How come i cannot find vtune 3.0 for linux in the download center?
http://downloadfinder.intel.com/scripts-df/Product_Search.asp?Prod_nm=vtune
0 Kudos
David_A_Intel1
Employee
802 Views
The VTune analyzer is a product for sale. You need to purchase it to use it. Unless, you want to use to for non-commercial reasons.
Regards,
0 Kudos
edwh
Beginner
802 Views
I'm also interested in this, but so far failing to get onto the premium site.
Is there any way to work round it? I've seen a suggestion that adding
extern void *sys_call_table;
EXPORT_SYMBOL(sys_call_table);
...into kallsyms.c and rebuilding the kernel might help, but it doesn't for me.
Alternatively, is there any way to manually map the addresses that VTune repots into symbols? I can't seem to reconcile them with /proc/kallsyms.
Edward.
0 Kudos
Maximillia_D_Intel
802 Views
Jeff,
The release specify support for Suse 9.0 for Itanium version, kernel version 2.65_7.97. Will VTune similar support Suse 9.0 for Itanium SP1, kernel version 2.65_7.139, e.g. ship a driver as part of the package?
Regards,
Max
0 Kudos
Reply